summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2010-12-30 14:11:43 +0000
committerJory Pratt <anarchy@gentoo.org>2010-12-30 14:11:43 +0000
commit42dce14c59fe5504ab1cdb4c3232f3328b7f68ce (patch)
tree1c390639c43598217b47cf8565c7385d957240fa /dev-libs/jemalloc
parentAdd fix for Memory Corruption Vulnerability (CVE-2010-2575, bug 334469), stra... (diff)
downloadhistorical-42dce14c59fe5504ab1cdb4c3232f3328b7f68ce.tar.gz
historical-42dce14c59fe5504ab1cdb4c3232f3328b7f68ce.tar.bz2
historical-42dce14c59fe5504ab1cdb4c3232f3328b7f68ce.zip
add jemalloc to tree
Package-Manager: portage-2.1.9.26/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/jemalloc')
-rw-r--r--dev-libs/jemalloc/ChangeLog10
-rw-r--r--dev-libs/jemalloc/Manifest5
-rw-r--r--dev-libs/jemalloc/files/jemalloc-strip-optimization.patch25
-rw-r--r--dev-libs/jemalloc/jemalloc-2.0.1.ebuild38
-rw-r--r--dev-libs/jemalloc/metadata.xml13
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/ChangeLog b/dev-libs/jemalloc/ChangeLog
new file mode 100644
index 000000000000..a45caa9aceef
--- /dev/null
+++ b/dev-libs/jemalloc/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/jemalloc
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/ChangeLog,v 1.1 2010/12/30 14:11:43 anarchy Exp $
+
+*jemalloc-2.0.1 (30 Dec 2010)
+
+ 30 Dec 2010; Jory A. Pratt <anarchy@gentoo.org> +jemalloc-2.0.1.ebuild,
+ +files/jemalloc-strip-optimization.patch, +metadata.xml:
+ initial import to tree
+
diff --git a/dev-libs/jemalloc/Manifest b/dev-libs/jemalloc/Manifest
new file mode 100644
index 000000000000..5bf4efc42305
--- /dev/null
+++ b/dev-libs/jemalloc/Manifest
@@ -0,0 +1,5 @@
+AUX jemalloc-strip-optimization.patch 800 RMD160 a55b49895ceb9cc48f6fe12215b45f5a8c2e7b15 SHA1 ec662a39f02c5f42344ba987e881828c0df0c580 SHA256 a14ee193968e87d0d87a8146050dcad5a33042af119070dbfbac7d4eba9923ce
+DIST jemalloc-2.0.1.tar.bz2 195433 RMD160 e3e605c80d573598b4a26271ec093cb84b3e2d14 SHA1 35498ceb2c30c8129789cf6f99e8583a8bb54b79 SHA256 8c8a1f3b5b0588a8874cf18722b167f32f6bf7f73e45e2a7f2084d1df891b332
+EBUILD jemalloc-2.0.1.ebuild 823 RMD160 07f7d6f0ca69084b177a75ab32cb39aa9fa148a4 SHA1 88f6edce4c9a59d907760ddb2948bf6f2c16e160 SHA256 3ca0fa179cb77fc5ac1c287504b8cb3b954096d0e76d80eeee3637a745055438
+MISC ChangeLog 398 RMD160 1f68fac87243ebf19b7235974bbd23315d8d70aa SHA1 ce8da2af9f787eb05319977bc54f44d728f75ccc SHA256 21c1e5eb702d19897cfce61c9b4e7759e7fb9fe12f34aa3994da9d0bd8b4e7cf
+MISC metadata.xml 414 RMD160 bb98cdf93203dcc175b618895c8662ce1cbba956 SHA1 583105f24aed24787dfce96494205eaf9ebdce66 SHA256 b458048c550c170ab50b25d37198c84130841717989c6ad7d3f95ba6213cfa7e
diff --git a/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch b/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch
new file mode 100644
index 000000000000..60b7d6c22ff1
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-strip-optimization.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac 2010-02-22 12:07:05.000000000 +0100
++++ b/configure.ac 2010-02-22 12:08:29.000000000 +0100
+@@ -296,21 +296,6 @@
+ fi
+ AC_SUBST([enable_debug])
+
+-dnl Only optimize if not debugging.
+-if test "x$enable_debug" = "x0" -a "x$no_CFLAGS" = "xyes" ; then
+- dnl Make sure that an optimization flag was not specified in EXTRA_CFLAGS.
+- optimize="no"
+- echo "$EXTRA_CFLAGS" | grep "\-O" >/dev/null || optimize="yes"
+- if test "x${optimize}" = "xyes" ; then
+- if test "x$GCC" = "xyes" ; then
+- JE_CFLAGS_APPEND([-O3])
+- JE_CFLAGS_APPEND([-funroll-loops])
+- else
+- JE_CFLAGS_APPEND([-O])
+- fi
+- fi
+-fi
+-
+ dnl Do not enable statistics calculation by default.
+ AC_ARG_ENABLE([stats],
+ [AS_HELP_STRING([--enable-stats], [Enable statistics calculation/reporting])],
+
diff --git a/dev-libs/jemalloc/jemalloc-2.0.1.ebuild b/dev-libs/jemalloc/jemalloc-2.0.1.ebuild
new file mode 100644
index 000000000000..47da41635aeb
--- /dev/null
+++ b/dev-libs/jemalloc/jemalloc-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/jemalloc/jemalloc-2.0.1.ebuild,v 1.1 2010/12/30 14:11:43 anarchy Exp $
+
+EAPI="2"
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
+HOMEPAGE="http://www.canonware.com/jemalloc/"
+SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug profile stats"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-strip-optimization.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable profile prof) \
+ $(use_enable stats) \
+ || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
diff --git a/dev-libs/jemalloc/metadata.xml b/dev-libs/jemalloc/metadata.xml
new file mode 100644
index 000000000000..543b1a220574
--- /dev/null
+++ b/dev-libs/jemalloc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mozilla</herd>
+ <longdescription lang="en">
+ Jemalloc is a general-purpose scalable concurrent allocator
+ </longdescription>
+ <use>
+ <flag name='profile'>Enable allocation profiling</flag>
+ <flag name='stats'>Enable statistics calculation/reporting</flag>
+ </use>
+</pkgmetadata>
+