summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-18 12:12:55 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-18 12:12:55 +0000
commit2b9ed5cb78b38e858e4110234a43a0cdacf2bc98 (patch)
tree6c5b282a05b3be5c5104634de703faa897ee359e /dev-libs/gom/gom-0.3.0.ebuild
parentVersion bump (diff)
downloadhistorical-2b9ed5cb78b38e858e4110234a43a0cdacf2bc98.tar.gz
historical-2b9ed5cb78b38e858e4110234a43a0cdacf2bc98.tar.bz2
historical-2b9ed5cb78b38e858e4110234a43a0cdacf2bc98.zip
Version bump
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xA188FBD4
Diffstat (limited to 'dev-libs/gom/gom-0.3.0.ebuild')
-rw-r--r--dev-libs/gom/gom-0.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/gom/gom-0.3.0.ebuild b/dev-libs/gom/gom-0.3.0.ebuild
new file mode 100644
index 000000000000..42e6cfe20c3d
--- /dev/null
+++ b/dev-libs/gom/gom-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gom/gom-0.3.0.ebuild,v 1.1 2015/02/18 12:12:54 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GObject to SQLite object mapper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}