summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2003-05-14 10:41:07 +0000
committerStefan Jones <cretin@gentoo.org>2003-05-14 10:41:07 +0000
commite5d78a406288b3dd6e075ff28e8c2a19afd01a21 (patch)
treeeb631159d4ac2ff1a08fcc897206ce42a415f7dc /dev-libs/elfutils
parentfixed ACCEPT_KEYWORDS and RDEPEND (diff)
downloadhistorical-e5d78a406288b3dd6e075ff28e8c2a19afd01a21.tar.gz
historical-e5d78a406288b3dd6e075ff28e8c2a19afd01a21.tar.bz2
historical-e5d78a406288b3dd6e075ff28e8c2a19afd01a21.zip
Fix compile problem with newer binutils
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/elfutils-0.76-r2.ebuild53
-rw-r--r--dev-libs/elfutils/files/digest-elfutils-0.76-r21
-rw-r--r--dev-libs/elfutils/files/elfutils-0.76-hidden.diff24
4 files changed, 84 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 5b0a6f1821fe..f44f887cb84b 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.8 2003/04/24 22:06:52 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.9 2003/05/14 10:41:07 cretin Exp $
+
+*elfutils-0.76-r2 (14 May 2003)
+
+ 14 May 2003; Stefan Jones <cretin@gentoo.org> elfutils-0.76-hidden.diff :
+ Added patch to fix bug #20948
*elfutils-0.76-r1 (24 Apr 2003)
diff --git a/dev-libs/elfutils/elfutils-0.76-r2.ebuild b/dev-libs/elfutils/elfutils-0.76-r2.ebuild
new file mode 100644
index 000000000000..6a0a9d479a2b
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.76-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.76-r2.ebuild,v 1.1 2003/05/14 10:41:07 cretin Exp $
+
+inherit eutils
+
+IUSE=""
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Libraries and utilities to handle compiled objects.
+This should be a drop in replacement for libelf."
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.redhat.com/"
+
+LICENSE="OpenSoftware"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-3.2.1-r6
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-hidden.diff
+
+ for x in $(find ${S}/ -name Makefile.in) ; do
+ cp ${x} ${x}.orig
+ sed -e 's:-Werror::g' \
+ ${x}.orig > ${x}
+ done
+}
+
+src_compile() {
+ econf --program-prefix="eu-" \
+ --enable-shared || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Remove stuff we do not use ...
+ rm -f ${D}/usr/bin/eu-ld
+ rm -f ${D}/usr/include/elfutils/lib{asm,dw,dwarf}.h
+ rm -f ${D}/usr/lib/lib{asm,dw}-${PV}.so
+ rm -f ${D}/usr/lib/lib{asm,dw}.so*
+ rm -f ${D}/usr/lib/lib{asm,dw,dwarf}.a
+ rm -rf ${D}/usr/usr
+
+ dodoc AUTHORS COPYING ChangeLog NEWS NOTES README THANKS TODO
+}
diff --git a/dev-libs/elfutils/files/digest-elfutils-0.76-r2 b/dev-libs/elfutils/files/digest-elfutils-0.76-r2
new file mode 100644
index 000000000000..566928d8de69
--- /dev/null
+++ b/dev-libs/elfutils/files/digest-elfutils-0.76-r2
@@ -0,0 +1 @@
+MD5 51adf608642cd5fd6a4e3f25545b3c42 elfutils-0.76.tar.gz 746988
diff --git a/dev-libs/elfutils/files/elfutils-0.76-hidden.diff b/dev-libs/elfutils/files/elfutils-0.76-hidden.diff
new file mode 100644
index 000000000000..4f4f03138ed5
--- /dev/null
+++ b/dev-libs/elfutils/files/elfutils-0.76-hidden.diff
@@ -0,0 +1,24 @@
+diff -ur elfutils-0.76.orig/libelf/elf_fill.c elfutils-0.76/libelf/elf_fill.c
+--- elfutils-0.76.orig/libelf/elf_fill.c 2002-11-29 01:13:55.000000000 +0000
++++ elfutils-0.76/libelf/elf_fill.c 2003-05-14 11:08:46.000000000 +0100
+@@ -21,7 +21,7 @@
+ #include "libelfP.h"
+
+
+-int __libelf_fill_byte;
++int __libelf_fill_byte = 0;
+
+
+ void
+diff -ur elfutils-0.76.orig/libelf/elf_version.c elfutils-0.76/libelf/elf_version.c
+--- elfutils-0.76.orig/libelf/elf_version.c 2002-11-29 01:13:55.000000000 +0000
++++ elfutils-0.76/libelf/elf_version.c 2003-05-14 11:03:33.000000000 +0100
+@@ -20,7 +20,7 @@
+
+
+ /* Is the version initialized? */
+-int __libelf_version_initialized;
++int __libelf_version_initialized = 0;
+
+ /* Currently selected version. */
+ unsigned int __libelf_version = EV_CURRENT;