summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-01-20 14:17:34 +0000
committerDane Smith <c1pher@gentoo.org>2011-01-20 14:17:34 +0000
commita275ef1cde6beb5f30dd8b9e70c4b4f8428898da (patch)
tree9afff46704a5f7dada7218bfba525011f39db8ac /dev-libs/cryptlib/files
parentstable x86, bug 272454 (diff)
downloadhistorical-a275ef1cde6beb5f30dd8b9e70c4b4f8428898da.tar.gz
historical-a275ef1cde6beb5f30dd8b9e70c4b4f8428898da.tar.bz2
historical-a275ef1cde6beb5f30dd8b9e70c4b4f8428898da.zip
dev-libs/cryptlib version bump wrt bug 351834.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux i686
Diffstat (limited to 'dev-libs/cryptlib/files')
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.0-external-zlib.patch35
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.4.0-python.patch50
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.0-external-zlib.patch b/dev-libs/cryptlib/files/cryptlib-3.4.0-external-zlib.patch
new file mode 100644
index 000000000000..5b599b76294a
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.0-external-zlib.patch
@@ -0,0 +1,35 @@
+--- makefile 2011-01-18 14:23:05.000000000 -0500
++++ makefile.new 2011-01-18 14:25:47.000000000 -0500
+@@ -259,7 +259,7 @@
+ OBJS = $(BNOBJS) $(CERTOBJS) $(CRYPTOBJS) $(CTXOBJS) $(DEVOBJS) \
+ $(ENCDECOBJS) $(ENVOBJS) $(HASHOBJS) $(IOOBJS) $(KEYSETOBJS) \
+ $(KRNLOBJS) $(LIBOBJS) $(MECHOBJS) $(MISCOBJS) $(SESSOBJS) \
+- $(ZLIBOBJS) $(OSOBJS)
++ $(OSOBJS)
+
+ # Object files for the self-test code
+
+@@ -1477,7 +1477,7 @@
+
+ $(SLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @./tools/buildsharedlib.sh $(OSNAME) $(SLIBNAME) $(LD) $(OBJS) \
+- $(EXTRAOBJS)
++ $(EXTRAOBJS) -lz
+
+ $(DYLIBNAME): $(OBJS) $(EXTRAOBJS) $(TESTOBJS)
+ @$(LD) -dynamiclib -compatibility_version $(MAJ).$(MIN) \
+--- envelope/envelope.h 2010-12-14 23:16:40.000000000 -0500
++++ envelope.h.new 2011-01-18 14:28:06.000000000 -0500
+@@ -17,11 +17,7 @@
+ #endif /* Compiler-specific includes */
+ #endif /* _STREAM_DEFINED */
+ #ifdef USE_COMPRESSION
+- #if defined( INC_ALL )
+- #include "zlib.h"
+- #else
+- #include "zlib/zlib.h"
+- #endif /* Compiler-specific includes */
++ #include <zlib.h>
+ #endif /* USE_COMPRESSION */
+
+ /****************************************************************************
diff --git a/dev-libs/cryptlib/files/cryptlib-3.4.0-python.patch b/dev-libs/cryptlib/files/cryptlib-3.4.0-python.patch
new file mode 100644
index 000000000000..e7aa41376497
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.4.0-python.patch
@@ -0,0 +1,50 @@
+--- bindings/setup.py 2010-12-13 04:51:58.000000000 -0500
++++ setup.py.new 2011-01-19 08:41:40.000000000 -0500
+@@ -15,7 +15,7 @@
+ ext = Extension("cryptlib_py",
+ sources=["bindings/python.c"],
+- library_dirs=['..'],
++ library_dirs=['.'],
+- libraries=['cl'])
++ libraries=['cl','resolv'])
+
+ setup(name="cryptlib_py", ext_modules=[ext])
+
+--- bindings/python.c 2010-11-30 18:35:52.000000000 -0500
++++ python.c.new 2011-01-19 09:05:43.000000000 -0500
+@@ -358,6 +358,7 @@
+ return(processStatus(status));
+ }
+
++/*
+ static PyObject* python_cryptGenerateKeyAsync(PyObject* self, PyObject* args)
+ {
+ int status = 0;
+@@ -396,6 +397,7 @@
+
+ return(processStatus(status));
+ }
++*/
+
+ static PyObject* python_cryptEncrypt(PyObject* self, PyObject* args)
+ {
+@@ -1429,9 +1431,9 @@
+ { "cryptDestroyContext", python_cryptDestroyContext, METH_VARARGS },
+ { "cryptDestroyObject", python_cryptDestroyObject, METH_VARARGS },
+ { "cryptGenerateKey", python_cryptGenerateKey, METH_VARARGS },
+- { "cryptGenerateKeyAsync", python_cryptGenerateKeyAsync, METH_VARARGS },
+- { "cryptAsyncQuery", python_cryptAsyncQuery, METH_VARARGS },
+- { "cryptAsyncCancel", python_cryptAsyncCancel, METH_VARARGS },
++// { "cryptGenerateKeyAsync", python_cryptGenerateKeyAsync, METH_VARARGS },
++// { "cryptAsyncQuery", python_cryptAsyncQuery, METH_VARARGS },
++// { "cryptAsyncCancel", python_cryptAsyncCancel, METH_VARARGS },
+ { "cryptEncrypt", python_cryptEncrypt, METH_VARARGS },
+ { "cryptDecrypt", python_cryptDecrypt, METH_VARARGS },
+ { "cryptSetAttribute", python_cryptSetAttribute, METH_VARARGS },
+@@ -4892,4 +4894,4 @@
+ v = Py_BuildValue("i", -50);
+ PyDict_SetItemString(moduleDict, "CRYPT_ENVELOPE_RESOURCE", v);
+ Py_DECREF(v); /* Need resource to proceed */
+-}
+\ No newline at end of file
++}