summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-20 04:10:49 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-20 04:10:49 +0000
commita2f8740aa0160d5a84ef734283907e73892dc1c5 (patch)
treeea6270741c031a70d5c5d9adbc1a6c0e40a3cf9e /dev-libs/boost
parentadded threadsonly flag for boost (diff)
downloadhistorical-a2f8740aa0160d5a84ef734283907e73892dc1c5.tar.gz
historical-a2f8740aa0160d5a84ef734283907e73892dc1c5.tar.bz2
historical-a2f8740aa0160d5a84ef734283907e73892dc1c5.zip
fine grained control over built and installed libs
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/Manifest10
-rw-r--r--dev-libs/boost/boost-1.32.0-r2.ebuild212
-rw-r--r--dev-libs/boost/files/digest-boost-1.32.0-r21
4 files changed, 226 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index af4320ec1b69..4f4f7f989874 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.48 2005/03/23 04:23:22 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.49 2005/04/20 04:10:49 morfic Exp $
+
+*boost-1.32.0-r2 (16 Apr 2005)
+
+ 16 Apr 2005; Daniel Goller <morfic@gentoo.org> +boost-1.32.0-r2.ebuild:
+ 1.32.0-r2 allows fine grained install of boost, shorter compile times and
+ smaller space requirement are now possible
22 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
Fixed html doc install path, closing bug 85938, thanks Benoit Boissinot
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 0c745334dc71..be9c5a5e66ac 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -4,8 +4,9 @@ Hash: SHA1
MD5 12f996aa5f489e4e51055e537ea059a8 boost-1.31.0.ebuild 3967
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
+MD5 2a4ebcecb719de03390260afba73186d boost-1.32.0-r2.ebuild 5690
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
-MD5 886f33e7ae6591a7a976f99e7c71487d ChangeLog 7208
+MD5 39c87226b5df339b61bb7ebbdb7d390a ChangeLog 7436
MD5 ac17509c51769ef73346e3d3d7733f67 metadata.xml 347
MD5 7403141309dea4e7a191766eba147299 boost-1.32.0-r1.ebuild 5379
MD5 4759f9391ad73c487d4f6b3dbf8632a8 boost-1.30.2.ebuild 2960
@@ -15,10 +16,11 @@ MD5 a09c431deb3a25504525921685cd0e57 files/digest-boost-1.30.2 66
MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r1 67
+MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r2 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCQOW7UpKYMelfdYERAveRAJ4nfwFIdTkouuo0yoz26Ni9uztugQCfd0QF
-2oJSVvi7MmPgjHCmUPNELnA=
-=hMgV
+iD8DBQFCZdU8UpKYMelfdYERAnWvAJ48/WTqwSXx2K4rcVBYvLOUvTqvIACfcrRX
+EP+l/HgqW8QN3qQ69aDd4Fk=
+=Yaa4
-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.32.0-r2.ebuild b/dev-libs/boost/boost-1.32.0-r2.ebuild
new file mode 100644
index 000000000000..5d33c36fecd1
--- /dev/null
+++ b/dev-libs/boost/boost-1.32.0-r2.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r2.ebuild,v 1.1 2005/04/20 04:10:49 morfic Exp $
+
+# This ebuild was generated by Ebuilder v0.4.
+inherit python multilib eutils
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+BOOST_PV1=${PV/./_}
+BOOST_PV=${BOOST_PV1/./_}
+SRC_URI="mirror://sourceforge/boost/${PN}_${BOOST_PV}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
+IUSE="icc debug threads threadsonly static"
+
+DEPEND="!icc? ( sys-devel/gcc )
+ icc? ( >=dev-lang/icc-8.0.055 )
+ dev-lang/python"
+
+S="${WORKDIR}/${PN}_${BOOST_PV}"
+
+pkg_setup() {
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if use icc ; then
+ BOOST_TOOLSET="intel-linux"
+ TOOLSET_NAME="icc"
+ else
+ BOOST_TOOLSET="gcc"
+ TOOLSET_NAME="gcc"
+ fi
+
+ if use static ; then
+ BUILD="release <runtime-link>static"
+ else
+ BUILD="release <runtime-link>dynamic"
+ fi
+
+ if use debug ; then
+ BUILD="${BUILD} debug"
+ fi
+
+ if use threads && use threadsonly ; then
+ BUILD="${BUILD} <threading>multi"
+ fi
+
+ if use threads && ! use threadsonly ; then
+ BUILD="${BUILD} <threading>single/multi"
+ fi
+
+ if use ! threads ; then
+ BUILD="${BUILD} <threading>single"
+ fi
+
+ BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
+
+ # we dont like what get_number_of_jobs does, so we borrow what counts to us,
+ # thanks H?kan Wessberg <nacka-gentoo@refug.org>, bug #13565
+
+ if [ "`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | wc -l`" -gt 0 ]; then
+ ADMINOPTS="`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | cut -d= -f2 | sed 's/\"//g'`"
+ ADMINPARAM="`echo ${ADMINOPTS} | gawk '{match($0, /-j *[0-9]*/, opt); print opt[0]}'`"
+ NUMJOBS="${ADMINPARAM}"
+ fi
+
+ python_version
+}
+
+src_compile() {
+ # Build bjam, a jam variant, which is used instead of make
+ cd "${S}/tools/build/jam_src"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd "${S}"
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ fi
+
+
+}
+
+src_install () {
+ # install build tools
+ cd "${S}/tools/build"
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* index.html v1/ v2/ ${D}/usr/share/${PN} || die "failed to
+ install docs"
+ cd "${S}"
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system \
+ install || die "Install failed"
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system \
+ install || die "Install failed"
+ fi
+
+ # Install documentation; seems to be mostly under ${S}/lib
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css \
+ -A pdf -r more-r people -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${PF}/html/\{\} \;
+
+ #and finally set "default" links to -gcc-mt versions
+ cd ${D}/usr/lib
+
+ for fn in `ls -1 *.so|cut -d- -f1|sort|uniq`; do
+ if [ -f "$fn.so" ] ; then
+ dosym $fn.so /usr/lib/$fn-${TOOLSET_NAME}.so
+ fi
+ if [ -f "$fn-mt.so" ] ; then
+ dosym $fn-mt.so /usr/lib/$fn-${TOOLSET_NAME}-mt.so
+ fi
+ if [ -f "$fn-d.so" ] ; then
+ dosym $fn-d.so /usr/lib/$fn-${TOOLSET_NAME}-d.so
+ fi
+ if [ -f "$fn-mt-d.so" ] ; then
+ dosym $fn-mt-d.so /usr/lib/$fn-${TOOLSET_NAME}-mt-d.so
+ fi
+ done
+
+ for fn in `ls -1 *.a|cut -d- -f1|sort|uniq`; do
+ if [ -f "$fn.a" ] ; then
+ dosym $fn.a /usr/lib/$fn-${TOOLSET_NAME}.a
+ fi
+ if [ -f "$fn-mt.a" ] ; then
+ dosym $fn-mt.a /usr/lib/$fn-${TOOLSET_NAME}-mt.a
+ fi
+ if [ -f "$fn-d.a" ] ; then
+ dosym $fn-d.a /usr/lib/$fn-${TOOLSET_NAME}-d.a
+ fi
+ if [ -f "$fn-mt-d.a" ] ; then
+ dosym $fn-mt-d.a /usr/lib/$fn-${TOOLSET_NAME}-mt-d.a
+ fi
+ done
+
+ [[ $(get_libdir) == "lib" ]] || mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+}
diff --git a/dev-libs/boost/files/digest-boost-1.32.0-r2 b/dev-libs/boost/files/digest-boost-1.32.0-r2
new file mode 100644
index 000000000000..f5cfec51b895
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.32.0-r2
@@ -0,0 +1 @@
+MD5 e1d1fc7b8fc8c51df4564c2188ca51cb boost_1_32_0.tar.bz2 10181552