summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-06-20 14:09:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-06-20 14:09:07 +0000
commit1c731106b6f728d560d5e63ad10cb50cea797301 (patch)
tree2905f09f8268d6c5ba85300f6bb0ee2554e63d60 /dev-libs/boehm-gc/boehm-gc-6.5.ebuild
parentFixing #96555 (need autoreconf when using latest portage which sets $CBUILD) (diff)
downloadhistorical-1c731106b6f728d560d5e63ad10cb50cea797301.tar.gz
historical-1c731106b6f728d560d5e63ad10cb50cea797301.tar.bz2
historical-1c731106b6f728d560d5e63ad10cb50cea797301.zip
Version bumepd. Stable on x86.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-libs/boehm-gc/boehm-gc-6.5.ebuild')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-6.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-6.5.ebuild b/dev-libs/boehm-gc/boehm-gc-6.5.ebuild
new file mode 100644
index 000000000000..d7e46e9e0fce
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-6.5.ebuild,v 1.1 2005/06/20 14:09:07 matsuu Exp $
+
+MY_P=gc${PV/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="nocxx threads"
+
+RDEPEND="virtual/libc"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e '/^SUBDIRS/s/doc//' Makefile.in || die
+}
+
+src_compile() {
+ local myconf=""
+
+ if use nocxx ; then
+ myconf="${myconf} --disable-cplusplus"
+ else
+ myconf="${myconf} --enable-cplusplus"
+ fi
+
+ use threads || myconf="${myconf} --disable-threads"
+
+ econf ${myconf} || die "Configure failed..."
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # dist_noinst_HEADERS
+ insinto /usr/include/gc
+ doins include/{cord.h,ec.h,javaxfc.h}
+ insinto /usr/include/gc/private
+ doins include/private/*.h
+
+ dodoc README.QUICK doc/README* doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man GC_malloc.1
+}