summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-11-04 00:59:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-11-04 00:59:42 +0000
commit231e89cfd3d18888881aad9944636540a79a4c44 (patch)
tree6ef951e04ff8fbed7686a2cc6822be97823d8970 /dev-libs/blitz/blitz-0.9.ebuild
parentstabled x86, bug #152154 (diff)
downloadhistorical-231e89cfd3d18888881aad9944636540a79a4c44.tar.gz
historical-231e89cfd3d18888881aad9944636540a79a4c44.tar.bz2
historical-231e89cfd3d18888881aad9944636540a79a4c44.zip
made doc optional dependency in blitz-0.9 - bug #88042 thanks Roman Stanchak and Christian Faulhammer
Package-Manager: portage-2.1.2_rc1-r2
Diffstat (limited to 'dev-libs/blitz/blitz-0.9.ebuild')
-rw-r--r--dev-libs/blitz/blitz-0.9.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/blitz/blitz-0.9.ebuild b/dev-libs/blitz/blitz-0.9.ebuild
index fae8741b7977..f5d5d9017da7 100644
--- a/dev-libs/blitz/blitz-0.9.ebuild
+++ b/dev-libs/blitz/blitz-0.9.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.4 2006/10/07 17:28:55 pbienst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/blitz/blitz-0.9.ebuild,v 1.5 2006/11/04 00:59:42 dragonheart Exp $
inherit eutils toolchain-funcs fortran
DESCRIPTION="High-performance C++ numeric library"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.oonumerics.org/blitz"
-DEPEND="virtual/tetex
+DEPEND="doc? ( virtual/tetex )
icc? ( dev-lang/icc )"
IUSE="icc"
@@ -21,6 +21,7 @@ src_compile() {
local myconf
# ICC: if we've got it, use it
use icc && myconf="--with-cxx=icc" || myconf="--with-cxx=gcc"
+ use doc && myconf="$myconf --enable-latex-docs"
myconf="${myconf} --enable-shared"
export CC=$(tc-getCC) CXX=$(tc-getCXX)