summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-05 01:18:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-05 01:18:38 +0000
commit8e86c5f7582d00ab28f77733ddf5eae59c5d6481 (patch)
tree5a8161a63dc821bfd3e816fedcaf6743bc4da63a /dev-lang/gforth/gforth-0.7.0.ebuild
parentmake PATCHES an array (diff)
downloadhistorical-8e86c5f7582d00ab28f77733ddf5eae59c5d6481.tar.gz
historical-8e86c5f7582d00ab28f77733ddf5eae59c5d6481.tar.bz2
historical-8e86c5f7582d00ab28f77733ddf5eae59c5d6481.zip
whitespace
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.27.8 i686
Diffstat (limited to 'dev-lang/gforth/gforth-0.7.0.ebuild')
-rw-r--r--dev-lang/gforth/gforth-0.7.0.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-lang/gforth/gforth-0.7.0.ebuild b/dev-lang/gforth/gforth-0.7.0.ebuild
index 524c8f9a4cd2..70ac2598ed2d 100644
--- a/dev-lang/gforth/gforth-0.7.0.ebuild
+++ b/dev-lang/gforth/gforth-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.1 2009/01/04 22:47:42 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.7.0.ebuild,v 1.2 2009/01/05 01:18:38 mr_bones_ Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -27,27 +27,27 @@ src_unpack() {
src_compile() {
local myconf
-
+
# May want to add a USE flag for --enable-force-cdiv, if necessary
# At this point I do not know when that is appropriate, and I don't
# want to add an ebuild-specific USE flag without understanding.
-
+
if ! use emacs; then
myconf="--without-lispdir"
fi
-
+
econf ${myconf} || die "econf failed"
-
+
# Parallel make breaks here
emake -j1 || die "emake failed"
-
+
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
-
+
dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
-
+
if use emacs; then
elisp-install ${PN} gforth.el gforth.elc || die "elisp-install failed"
elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die