summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-28 18:18:59 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-28 18:18:59 +0000
commit03a4020f9e68d5344ce46e18c6c677e046b7a8ce (patch)
tree0d63ecce5bd326654123c6b8541b57a6f065182a /dev-java/commons-pool
parentAdded static USE flag support. (diff)
downloadhistorical-03a4020f9e68d5344ce46e18c6c677e046b7a8ce.tar.gz
historical-03a4020f9e68d5344ce46e18c6c677e046b7a8ce.tar.bz2
historical-03a4020f9e68d5344ce46e18c6c677e046b7a8ce.zip
version bump
Diffstat (limited to 'dev-java/commons-pool')
-rw-r--r--dev-java/commons-pool/ChangeLog7
-rw-r--r--dev-java/commons-pool/Manifest14
-rw-r--r--dev-java/commons-pool/commons-pool-1.2.ebuild51
-rw-r--r--dev-java/commons-pool/files/digest-commons-pool-1.21
4 files changed, 71 insertions, 2 deletions
diff --git a/dev-java/commons-pool/ChangeLog b/dev-java/commons-pool/ChangeLog
index b00a4d5eeb0b..57601c34ae37 100644
--- a/dev-java/commons-pool/ChangeLog
+++ b/dev-java/commons-pool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-pool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.16 2004/06/24 22:23:25 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/ChangeLog,v 1.17 2004/09/28 18:18:59 axxo Exp $
+
+*commons-pool-1.2 (28 Sep 2004)
+
+ 28 Sep 2004; Thomas Matthijs <axxo@gentoo.org> :
+ version bump
02 Jun 2004; Aron Griffis <agriffis@gentoo.org> commons-pool-1.1.ebuild:
Fix use invocation
diff --git a/dev-java/commons-pool/Manifest b/dev-java/commons-pool/Manifest
index 316bbea41f9d..17ad4cec984d 100644
--- a/dev-java/commons-pool/Manifest
+++ b/dev-java/commons-pool/Manifest
@@ -1,4 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 18a1181729b2ef335e48e5a14ee09027 commons-pool-1.2.ebuild 1404
MD5 ed396a259addd11dc8fd96c2d659521a commons-pool-1.1.ebuild 1421
-MD5 1af9acb9814d6ca036a26ef0099866f0 ChangeLog 2721
+MD5 e01a3d4553260ee8c26f8ce13fd97880 ChangeLog 2817
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 b8d9ac4e67767842878c535474df7961 files/digest-commons-pool-1.1 71
+MD5 d41c8c7c7d3b3490c197807fbe38f8a6 files/digest-commons-pool-1.2 72
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBWasX/rLF9B432nYRAtZlAJ9GpeUglLhlBEZ170Ffame+V+uCmACdFk/N
+HBJYKOg+6tpGzwXtsS3U6LQ=
+=JgaS
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-pool/commons-pool-1.2.ebuild b/dev-java/commons-pool/commons-pool-1.2.ebuild
new file mode 100644
index 000000000000..0121b0ef5087
--- /dev/null
+++ b/dev-java/commons-pool/commons-pool-1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.2.ebuild,v 1.1 2004/09/28 18:18:59 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
+HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
+SRC_URI="mirror://apache/jakarta/commons/pool/source/${PN}-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-collections-2.0
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-collections-2.0"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="jikes junit doc"
+
+S=${WORKDIR}/${PN}-${PV}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
+ use junit && echo "junit.jar=`java-config --classpath=junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags
+
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} dist || die "Compilation Failed"
+
+ if use junit; then
+ ant ${antflags} test || die "Testing Classes Failed"
+ fi
+
+ if use doc; then
+ ant javadoc || die "Unable to create documents"
+ fi
+}
+
+src_install () {
+ java-pkg_dojar dist/${PN}.jar
+ dodoc README.txt
+ dohtml STATUS.html PROPOSAL.html
+
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-pool/files/digest-commons-pool-1.2 b/dev-java/commons-pool/files/digest-commons-pool-1.2
new file mode 100644
index 000000000000..6c74ccf46989
--- /dev/null
+++ b/dev-java/commons-pool/files/digest-commons-pool-1.2
@@ -0,0 +1 @@
+MD5 e7dc9f479c6a4260f84f6751b434295a commons-pool-1.2-src.tar.gz 269500