summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-12 11:44:16 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-12 11:44:16 +0000
commit08f4c514102efaaf89fb0a4c75b0e4efdf99d43b (patch)
tree1233b71455938a2d461a36cd6cc2cd6ae9aceaee /dev-java/commons-cli
parentfix wrapper (diff)
downloadhistorical-08f4c514102efaaf89fb0a4c75b0e4efdf99d43b.tar.gz
historical-08f4c514102efaaf89fb0a4c75b0e4efdf99d43b.tar.bz2
historical-08f4c514102efaaf89fb0a4c75b0e4efdf99d43b.zip
dep/style fixes
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/Manifest10
-rw-r--r--dev-java/commons-cli/commons-cli-1.0-r4.ebuild20
2 files changed, 19 insertions, 11 deletions
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 1db17ef45197..a0c93af9c294 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 991744736534dc4715f8ba6fc8364dd1 commons-cli-1.0-r4.ebuild 1578
MD5 c4743c1ae713eab63c2fa9d7b1e5a0ec ChangeLog 3007
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 b534e655c6a40ff5b01098dddcda205c files/commons-cli-1.0-gentoo.diff 4407
MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r4 62
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC060l/rLF9B432nYRAp7pAKCOmUEHHeg8Y4ow5WFCp4YEmUea9wCdFfY8
+zJb5ZR0VEAwjG1JnERW1sSY=
+=0IAu
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-cli/commons-cli-1.0-r4.ebuild b/dev-java/commons-cli/commons-cli-1.0-r4.ebuild
index 5161be543498..79a1350f0f39 100644
--- a/dev-java/commons-cli/commons-cli-1.0-r4.ebuild
+++ b/dev-java/commons-cli/commons-cli-1.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.0-r4.ebuild,v 1.9 2005/06/05 12:56:15 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.0-r4.ebuild,v 1.10 2005/07/12 11:44:16 axxo Exp $
inherit java-pkg eutils
@@ -13,26 +13,24 @@ SLOT="1"
KEYWORDS="x86 sparc ppc amd64 ppc64"
IUSE="doc jikes junit source"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/commons-logging-1.0
+ >=dev-java/commons-lang-1.0"
DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}
junit? ( >=dev-java/junit-3.7 )
jikes? ( >=dev-java/jikes-1.21 )
source? ( app-arch/zip )
>=dev-java/ant-1.6.2"
-RDEPEND=">=virtual/jre-1.3
- >=dev-java/commons-logging-1.0
- >=dev-java/commons-lang-1.0"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff
- echo "commons-logging.jar=$(java-config -p commons-logging)" \
- >> build.properties
- echo "commons-lang.jar=$(java-config -p commons-lang)" \
- >> build.properties
- use junit && echo "junit.jar=$(java-config -p junit)" \
- >> build.properties
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ echo "commons-logging.jar=$(java-pkg_getjar commons-logging commons-logging.jar)" >> build.properties
+ echo "commons-lang.jar=$(java-pkg_getjars commons-lang)" >> build.properties
+ use junit && echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
}
src_compile() {