summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-17 18:16:18 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-17 18:16:18 +0000
commit2b2603e1c967720921c53317446299f02562c4d7 (patch)
treeea8e33b28610a019dae5155180e7a183304b61fc /dev-java/bsh/bsh-2.0_beta1-r1.ebuild
parentnamed the jar ${PN}.jar to its usable with java-pkg_jar-from (diff)
downloadhistorical-2b2603e1c967720921c53317446299f02562c4d7.tar.gz
historical-2b2603e1c967720921c53317446299f02562c4d7.tar.bz2
historical-2b2603e1c967720921c53317446299f02562c4d7.zip
named the jar ${PN}.jar to its usable with java-pkg_jar-from
Diffstat (limited to 'dev-java/bsh/bsh-2.0_beta1-r1.ebuild')
-rw-r--r--dev-java/bsh/bsh-2.0_beta1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/bsh/bsh-2.0_beta1-r1.ebuild b/dev-java/bsh/bsh-2.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..14f116adc35d
--- /dev/null
+++ b/dev-java/bsh/bsh-2.0_beta1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bsh/bsh-2.0_beta1-r1.ebuild,v 1.1 2004/09/17 18:16:18 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="BeanShell is a small, free, embeddable, Java source interpreter with object scripting language features."
+SRC_URI="http://www.beanshell.org/${P/_beta1/b1}.jar http://dev.gentoo.org/~axxo/distfiles/beanshell-icon.png"
+HOMEPAGE="http://www.beanshell.org/"
+KEYWORDS="x86 amd64 ~ppc"
+LICENSE="LGPL-2.1"
+SLOT="0"
+RDEPEND=">=virtual/jdk-1.2"
+DEPEND=">=virtual/jre-1.2"
+IUSE="kde gnome"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${P/_beta1/b1}.jar ${WORKDIR}/${PN}.jar
+}
+
+src_compile() {
+ einfo " This ebuild is binary-only (for now)."
+ einfo " If you get this to compile from source, please file a bug"
+ einfo " and let us know. http://bugs.gentoo.org/"
+}
+
+src_install() {
+ dobin ${FILESDIR}/bsh.Console ${FILESDIR}/bsh.Interpreter
+
+ java-pkg_dojar ${PN}.jar
+ if use gnome || use kde ; then
+ insinto /usr/share/pixmaps
+ doins ${DISTDIR}/beanshell-icon.png
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/beanshell.desktop
+ fi
+}