summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2012-02-18 22:14:16 +0000
committerVlastimil Babka <caster@gentoo.org>2012-02-18 22:14:16 +0000
commitf59caffd78733234ece237a8a6c0cbf6ab40f902 (patch)
tree90c7c655162356a4ab30cc14dba506ee274bc8b2 /dev-java/ant-nodeps
parentAdd hppa and ppc KEYWORDS (#397195) (diff)
downloadhistorical-f59caffd78733234ece237a8a6c0cbf6ab40f902.tar.gz
historical-f59caffd78733234ece237a8a6c0cbf6ab40f902.tar.bz2
historical-f59caffd78733234ece237a8a6c0cbf6ab40f902.zip
Version bump, bug #351850.
Package-Manager: portage-2.2.0_alpha85/cvs/Linux x86_64
Diffstat (limited to 'dev-java/ant-nodeps')
-rw-r--r--dev-java/ant-nodeps/ChangeLog9
-rw-r--r--dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-java/ant-nodeps/ChangeLog b/dev-java/ant-nodeps/ChangeLog
index 070725768672..6b52860897ff 100644
--- a/dev-java/ant-nodeps/ChangeLog
+++ b/dev-java/ant-nodeps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-nodeps
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ChangeLog,v 1.27 2011/12/31 12:09:48 sera Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ChangeLog,v 1.28 2012/02/18 22:13:17 caster Exp $
+
+*ant-nodeps-1.8.2 (18 Feb 2012)
+
+ 18 Feb 2012; Vlastimil Babka <caster@gentoo.org> +ant-nodeps-1.8.2.ebuild:
+ Version bump, bug #351850.
31 Dec 2011; Ralph Sennhauser <sera@gentoo.org> ant-nodeps-1.7.1.ebuild,
ant-nodeps-1.8.0.ebuild, ant-nodeps-1.8.1.ebuild:
diff --git a/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild b/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild
new file mode 100644
index 000000000000..f38d1616bfb2
--- /dev/null
+++ b/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ant-nodeps-1.8.2.ebuild,v 1.1 2012/02/18 22:13:17 caster Exp $
+
+EAPI="4"
+
+ANT_TASK_DEPNAME=""
+
+inherit ant-tasks
+
+DESCRIPTION="Apache Ant's optional tasks requiring no external deps"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # the classes were moved to ant-core in 1.8.2, this is just for compatibility
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar .
+}
+
+src_postinst() {
+ elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}