summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-27 14:02:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-27 14:02:32 +0000
commit6764a8c681c6d9133b4d42c798170a2eb1b1e472 (patch)
treef0a16586041a1e2150e04914086bdac212fbc4c6 /dev-haskell
parentfixing Manifest (diff)
downloadhistorical-6764a8c681c6d9133b4d42c798170a2eb1b1e472.tar.gz
historical-6764a8c681c6d9133b4d42c798170a2eb1b1e472.tar.bz2
historical-6764a8c681c6d9133b4d42c798170a2eb1b1e472.zip
touchups
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hmake/hmake-3.07.ebuild16
-rw-r--r--dev-haskell/hmake/hmake-3.08.ebuild19
2 files changed, 10 insertions, 25 deletions
diff --git a/dev-haskell/hmake/hmake-3.07.ebuild b/dev-haskell/hmake/hmake-3.07.ebuild
index ae724c91c122..a1bb0fcda80a 100644
--- a/dev-haskell/hmake/hmake-3.07.ebuild
+++ b/dev-haskell/hmake/hmake-3.07.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.07.ebuild,v 1.1 2003/04/22 08:27:53 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.07.ebuild,v 1.2 2003/06/27 14:02:32 vapier Exp $
DESCRIPTION="a make tool for Haskell programs"
-
HOMEPAGE="http://www.haskell.org/hmake/"
+SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
LICENSE="nhc98"
-
KEYWORDS="~x86"
SLOT="0"
IUSE="nhc98"
@@ -17,10 +16,6 @@ IUSE="nhc98"
DEPEND="nhc98? ( dev-lang/nhc98 )
!nhc98? ( virtual/ghc )"
-RDEPEND="${DEPEND}"
-
-SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
-
src_compile() {
if [ "`use nhc98`" ]; then
buildwith="--buildwith=nhc98"
@@ -44,10 +39,7 @@ src_compile() {
make || die "make failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
- # install HTML documentation
- cd docs/hmake
- dohtml *
+ dohtml docs/hmake/*
}
diff --git a/dev-haskell/hmake/hmake-3.08.ebuild b/dev-haskell/hmake/hmake-3.08.ebuild
index b65f7ef3de09..215c67c8e601 100644
--- a/dev-haskell/hmake/hmake-3.08.ebuild
+++ b/dev-haskell/hmake/hmake-3.08.ebuild
@@ -1,31 +1,27 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.08.ebuild,v 1.2 2003/06/24 15:10:10 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.08.ebuild,v 1.3 2003/06/27 14:02:32 vapier Exp $
-DESCRIPTION="a make tool for Haskell programs"
+inherit base
+DESCRIPTION="a make tool for Haskell programs"
HOMEPAGE="http://www.haskell.org/hmake/"
+SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
LICENSE="nhc98"
-
KEYWORDS="~x86"
SLOT="0"
IUSE="nhc98 readline"
-inherit base
-
# hmake can be build with either ghc or nhc98; we prefer ghc
# unless a use flag tells us otherwise
DEPEND="nhc98? ( dev-lang/nhc98 ) : ( virtual/ghc )
readline? ( sys-libs/readline )"
-
RDEPEND="readline? ( sys-libs/readline )
virtual/glibc
!nhc98? ( dev-libs/gmp
sys-libs/readline )"
-SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
-
src_compile() {
local buildwith
local arch
@@ -60,10 +56,7 @@ src_compile() {
make || die "make failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
-
- # install HTML documentation
- cd docs/hmake
- dohtml *
+ dohtml docs/hmake/*
}