summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-02-23 00:52:26 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-02-23 00:52:26 +0000
commiteac6837450641834347705735eaf000bb0536ff8 (patch)
treefc66247f40c3c9560c0f832b7922244b1ae65169 /dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild
parentMask dev-haskel/hsql-* ebuilds 'til they've been fully tested. (diff)
downloadhistorical-eac6837450641834347705735eaf000bb0536ff8.tar.gz
historical-eac6837450641834347705735eaf000bb0536ff8.tar.bz2
historical-eac6837450641834347705735eaf000bb0536ff8.zip
Initial import.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild')
-rw-r--r--dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild b/dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild
new file mode 100644
index 000000000000..ddb5916e84b9
--- /dev/null
+++ b/dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hsql-sqlite/hsql-sqlite-1.7.ebuild,v 1.1 2006/02/23 00:51:54 dcoutts Exp $
+
+CABAL_FEATURES="lib haddock"
+inherit base haskell-cabal
+
+DESCRIPTION="SQLite3 driver HSQL"
+HOMEPAGE="http://htoolkit.sourceforge.net/"
+SRC_URI="mirror://gentoo/HSQL-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/ghc-6.4.1
+ =dev-haskell/hsql-${PV}
+ >=dev-db/sqlite-3.0"
+
+S="${WORKDIR}/HSQL/SQLite3"
+
+src_unpack() {
+ base_src_unpack
+
+ echo '> import Distribution.Simple' > "${S}/Setup.lhs"
+ echo '> main = defaultMain' >> "${S}/Setup.lhs"
+
+ echo 'extra-libraries: sqlite3' >> "${S}/SQLite3.cabal"
+}