summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2005-02-24 21:52:55 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2005-02-24 21:52:55 +0000
commit5735ad89778c821a725894a11f52e3ec27b0c85d (patch)
tree94ec9e2f168ff51ed9ceab4a3288f873d4a7c662 /dev-games
parentRemoving icc support. Fixes bug #60566 (diff)
downloadhistorical-5735ad89778c821a725894a11f52e3ec27b0c85d.tar.gz
historical-5735ad89778c821a725894a11f52e3ec27b0c85d.tar.bz2
historical-5735ad89778c821a725894a11f52e3ec27b0c85d.zip
cvs snapshot for planeshift
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/crystalspace/ChangeLog5
-rw-r--r--dev-games/crystalspace/Manifest8
-rw-r--r--dev-games/crystalspace/crystalspace-0.98.4.20050224.ebuild72
-rw-r--r--dev-games/crystalspace/crystalspace-0.98.4.ebuild5
-rw-r--r--dev-games/crystalspace/files/crystalspace-0.98.4-gl.patch2
-rw-r--r--dev-games/crystalspace/files/digest-crystalspace-0.98.4.200502241
6 files changed, 86 insertions, 7 deletions
diff --git a/dev-games/crystalspace/ChangeLog b/dev-games/crystalspace/ChangeLog
index e9d83199c290..c47fafe5fa6e 100644
--- a/dev-games/crystalspace/ChangeLog
+++ b/dev-games/crystalspace/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/crystalspace
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.11 2005/01/01 17:58:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/ChangeLog,v 1.12 2005/02/24 21:52:55 lordvan Exp $
+
+ 24 Feb 2005; Thomas Raschbacher <lordvan@gentoo.org> : crystalspace-0.98.4.20050224.ebuild
+ cvs snapshot for planeshift
27 Dec 2004; Mike Frysinger <vapier@gentoo.org> +files/0.98.4-gl.patch,
crystalspace-0.98.4.ebuild:
diff --git a/dev-games/crystalspace/Manifest b/dev-games/crystalspace/Manifest
index 7ba9602b21ca..691a7f0250ff 100644
--- a/dev-games/crystalspace/Manifest
+++ b/dev-games/crystalspace/Manifest
@@ -1,5 +1,7 @@
-MD5 ee57a512766bae0dfcf88452136cc05f ChangeLog 1833
+MD5 d80d4acb51d9679899d376c7a804bf97 crystalspace-0.98.4.ebuild 1893
+MD5 d178cc529610c392511feefa8ece2d36 crystalspace-0.98.4.20050224.ebuild 1958
+MD5 3df01d1a71b43ffcb30864013c1847da ChangeLog 1954
MD5 e4c7a49ca08eb200cfa0a9f9246e2257 metadata.xml 959
-MD5 518dc79b41c9eb6e71428c8b0c1a16e6 crystalspace-0.98.4.ebuild 1812
-MD5 0e0e7b896ce777aa3f4d85f5a48feb25 files/crystalspace-0.98.4-gl.patch 10651
MD5 bec0edb0863c282510494dc014bbf750 files/digest-crystalspace-0.98.4 63
+MD5 bb4bd5565667c14a0d7377fda90db568 files/crystalspace-0.98.4-gl.patch 10653
+MD5 dc4db504020f9a21fe8e24ecd6ceac67 files/digest-crystalspace-0.98.4.20050224 83
diff --git a/dev-games/crystalspace/crystalspace-0.98.4.20050224.ebuild b/dev-games/crystalspace/crystalspace-0.98.4.20050224.ebuild
new file mode 100644
index 000000000000..f6b0cd600e5d
--- /dev/null
+++ b/dev-games/crystalspace/crystalspace-0.98.4.20050224.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.20050224.ebuild,v 1.1 2005/02/24 21:52:55 lordvan Exp $
+
+inherit eutils
+
+#MY_P="cs${PV:2:2}_00${PV:5:1}"
+MY_P="${P}"
+DESCRIPTION="portable 3D Game Development Kit written in C++"
+HOMEPAGE="http://crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crystal/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="3ds mikmod mng oggvorbis openal truetype"
+
+RDEPEND="sys-libs/zlib
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b
+ mng? ( media-libs/libmng )
+ mikmod? ( media-libs/libmikmod )
+ 3ds? ( media-libs/lib3ds )
+ truetype? ( >=media-libs/freetype-2.0 )
+ openal? ( media-libs/openal )
+ cal3d? ( >=media-libs/cal3d-0.10.0 )
+ oggvorbis? (
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0 )
+ dev-games/ode
+ >=dev-lang/perl-5.6.1"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51
+ || ( dev-util/jam dev-util/boost-jam )
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/CS"
+
+CRYSTAL_PREFIX="/opt/crystal"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo "CRYSTAL=\"${CRYSTAL_PREFIX}\"" > 90crystalspace
+}
+
+src_compile() {
+ CONFIGURE_OPTS=""
+ if use cal3d; then
+ CONFIGURE_OPTS=" --with-libcal3d=/home/andrew/development/cal3d "
+ fi
+ ./configure --prefix=${CRYSTAL_PREFIX} ${CONFIGURE_OPTS} || die "configure failed"
+ jam all || die "compile failed"
+}
+
+src_install() {
+ jam -sprefix="${D}"${CRYSTAL_PREFIX} install
+
+ # symlink for cs-config
+ dodir /usr/bin
+ dosym ${CRYSTAL_PREFIX}/bin/cs-config /usr/bin/cs-config
+
+ # make sure these files dont have $D
+ dosed ${CRYSTAL_PREFIX}/{bin/cs-config,etc/crystalspace/vfs.cfg}
+
+ # fix perms so everyone can read these things
+ find "${D}"/${CRYSTAL_PREFIX} -type f -exec chmod a+r '{}' \;
+ find "${D}"/${CRYSTAL_PREFIX} -type d -exec chmod a+rx '{}' \;
+ chmod a+rx "${D}"/${CRYSTAL_PREFIX}/bin/*
+
+ doenvd 90crystalspace
+}
diff --git a/dev-games/crystalspace/crystalspace-0.98.4.ebuild b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
index aa7c3a0a2ce7..4a8a36a5c3c5 100644
--- a/dev-games/crystalspace/crystalspace-0.98.4.ebuild
+++ b/dev-games/crystalspace/crystalspace-0.98.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.8 2005/02/23 17:01:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace/crystalspace-0.98.4.ebuild,v 1.9 2005/02/24 21:52:55 lordvan Exp $
inherit eutils
@@ -44,7 +44,8 @@ src_unpack() {
}
src_compile() {
- ./configure --prefix=${CRYSTAL_PREFIX} || die "configure failed"
+ CONFIGURE_OPTS="--with-libcal3d=/home/andrew/development/cal3d"
+ ./configure --prefix=${CRYSTAL_PREFIX} ${CONFIGURE_OPTS} || die "configure failed"
jam all || die "compile failed"
}
diff --git a/dev-games/crystalspace/files/crystalspace-0.98.4-gl.patch b/dev-games/crystalspace/files/crystalspace-0.98.4-gl.patch
index 6e426186fa5f..d281ea5d34f2 100644
--- a/dev-games/crystalspace/files/crystalspace-0.98.4-gl.patch
+++ b/dev-games/crystalspace/files/crystalspace-0.98.4-gl.patch
@@ -386,7 +386,7 @@ diff -u -r1.31 -r1.32
#include <GL/gl.h>
#endif
-+#include "cssysdef.h"
++//#include "cssysdef.h"
+
/*
Appear in the ARB_shader_objects ext spec.
diff --git a/dev-games/crystalspace/files/digest-crystalspace-0.98.4.20050224 b/dev-games/crystalspace/files/digest-crystalspace-0.98.4.20050224
new file mode 100644
index 000000000000..f10aec8f6c42
--- /dev/null
+++ b/dev-games/crystalspace/files/digest-crystalspace-0.98.4.20050224
@@ -0,0 +1 @@
+MD5 b45b3cba7f31e2c38244a343b7943a34 crystalspace-0.98.4.20050224.tar.bz2 22352421