summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-01-22 10:45:58 +0000
committerPacho Ramos <pacho@gentoo.org>2012-01-22 10:45:58 +0000
commit969a60c4069bc671274ae7f597c6e4fdf5d32bb5 (patch)
tree6369bd5f30c07928a24e2b45539e84a1148369c0 /dev-dotnet
parentDrop old. (diff)
downloadhistorical-969a60c4069bc671274ae7f597c6e4fdf5d32bb5.tar.gz
historical-969a60c4069bc671274ae7f597c6e4fdf5d32bb5.tar.bz2
historical-969a60c4069bc671274ae7f597c6e4fdf5d32bb5.zip
Version bump.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/mono-nat/ChangeLog9
-rw-r--r--dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild42
-rw-r--r--dev-dotnet/monotorrent/Manifest12
3 files changed, 54 insertions, 9 deletions
diff --git a/dev-dotnet/mono-nat/ChangeLog b/dev-dotnet/mono-nat/ChangeLog
index 17fc18569b19..5c613b0b0903 100644
--- a/dev-dotnet/mono-nat/ChangeLog
+++ b/dev-dotnet/mono-nat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/mono-nat
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-nat/ChangeLog,v 1.9 2010/10/07 19:48:22 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-nat/ChangeLog,v 1.10 2012/01/22 10:45:58 pacho Exp $
+
+*mono-nat-1.1.0 (22 Jan 2012)
+
+ 22 Jan 2012; Pacho Ramos <pacho@gentoo.org> +mono-nat-1.1.0.ebuild:
+ Version bump.
07 Oct 2010; Pacho Ramos <pacho@gentoo.org> -mono-nat-1.0.1.ebuild:
Remove old.
diff --git a/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild b/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild
new file mode 100644
index 000000000000..eb66ef465556
--- /dev/null
+++ b/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-nat/mono-nat-1.1.0.ebuild,v 1.1 2012/01/22 10:45:58 pacho Exp $
+
+EAPI="4"
+
+inherit mono multilib
+
+MY_PN=Mono.Nat
+
+DESCRIPTION="Mono.Nat is a C# library used for automatic port forwarding, using either uPnP or nat-pmp."
+HOMEPAGE="http://projects.qnetp.net/projects/show/mono-nat"
+SRC_URI="http://projects.qnetp.net/attachments/download/76/${P}.tar.gz
+ mirror://gentoo/mono.snk.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs -keyfile:${WORKDIR}/mono.snk"
+}
+
+src_install() {
+ egacinstall $(find . -name "Mono.Nat.dll")
+ dodir /usr/$(get_libdir)/pkgconfig
+ ebegin "Installing .pc file"
+ sed \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PACKAGENAME@:${MY_PN}:" \
+ -e "s:@DESCRIPTION@:${DESCRIPTION}:" \
+ -e "s:@VERSION@:${PV}:" \
+ -e 's;@LIBS@;-r:${libdir}/mono/mono-nat/Mono.Nat.dll;' \
+ "${FILESDIR}"/${PN}.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/mono.nat.pc \
+ || die "sed failed"
+ PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --exists mono.nat || die ".pc file failed to validate."
+ eend $?
+}
diff --git a/dev-dotnet/monotorrent/Manifest b/dev-dotnet/monotorrent/Manifest
index f4175de8aee2..b6215434b535 100644
--- a/dev-dotnet/monotorrent/Manifest
+++ b/dev-dotnet/monotorrent/Manifest
@@ -1,18 +1,16 @@
-----BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA256
+Hash: SHA1
AUX monotorrent.pc.in 159 RMD160 de5efebeeb059bdd1b7101a53f84e20e5af66d20 SHA1 e87063b2f5e09dd95900bcd1ae83820745c64fc6 SHA256 5a8a911bd21e5a79b5b5ba8e4ef0e2f5276e1d8200cf3f8fb57be6c1f2bb17ea
DIST mono.snk.bz2 785 RMD160 2e30f95781501c734073f377f4b2bd1e04db0409 SHA1 9e32703b6ae86db332c73354fb79dcc61a6b7b17 SHA256 0cc2ca58f90773eafa8460dfb8ff4ac6238b68106eb1631348a800091a6ff3de
-DIST monotorrent-0.72.tar.gz 269544 RMD160 708aad857fe5dbe79f4dcbccd4dda027bc438e0d SHA1 aecf8e80ec72c0d4a94bf440df08226c8025b204 SHA256 5e68383448ff703522fe8df4f3712bf15a33f1f2245c9ad8249b723d9109d9d4
DIST monotorrent-0.80.tar.gz 290837 RMD160 164203fdb8c6c91522a081844c38288019f443dd SHA1 6e391bacf9b637bb620a2665ba5540f33bf6ea24 SHA256 d9c079dc4757e637f1e81a4d8b8a153394fcbeff8dd572bb0622e3430c5a34cf
-EBUILD monotorrent-0.72.ebuild 1473 RMD160 b37d6b6095786279d60600ac541bb563328f01af SHA1 47369bc661fb61baa5cb29b2afe98430f94089ec SHA256 530074689290c60ceb1bb462e2d8080d0b118ea7aca0196ab59228c092fdab93
EBUILD monotorrent-0.80.ebuild 1472 RMD160 c6ab97fe3a0429efcf3449ca979f2065fe95cf88 SHA1 ca21ecb5a79a1b6ce31e8a4f5fbeed1c5b3a5ffd SHA256 040a15e2950d3c3f4316ab4f6d6d3128eb2cd8e07871b2555ccfd36201ff0f0c
-MISC ChangeLog 1394 RMD160 8e36ddab6bf9551994c44461f3a1c3e2a188807c SHA1 9532dd6a48bd7f192fc6ea5e308417950ecdf280 SHA256 2f76e0f1d977346b1a07dedae09013d6428b7ba21f052baf14006fca3e0401dc
+MISC ChangeLog 1478 RMD160 14a83df4c8fbb65285519067d26799416eb0a04e SHA1 176c7558c104c47b516085aae2f0476102317617 SHA256 c8c2a67c412765d05c93b9cd8ac9527b9980c96805b3239db19cbfe41ca90647
MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
-iF4EAREIAAYFAk3K4wkACgkQmWq1bYTyC0ONAAD9GXtz6LgeydoeYoyBOPfsfofw
-uX4n8H51C8YGeX9L7zsBALv1A5IPnasGhUm/+PPRMv9vcsQe/KIhXZST+VPn8SgB
-=xCvM
+iEYEARECAAYFAk8b6a0ACgkQCaWpQKGI+9RUZACcDtBccPwwVAq+3dYJu6/LbP8H
+UccAn3Sll/O22TPwnElbc76QNpfFg7A4
+=OK07
-----END PGP SIGNATURE-----