summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-22 20:10:39 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-22 20:10:39 +0000
commit160c19a410152d06aa243976383682189eccf71f (patch)
tree627f0fd51426359a503f45ca81a58064eabf2c96 /dev-db/unixODBC
parentNow supports USE java tcltk perl python ssl nls (diff)
downloadhistorical-160c19a410152d06aa243976383682189eccf71f.tar.gz
historical-160c19a410152d06aa243976383682189eccf71f.tar.bz2
historical-160c19a410152d06aa243976383682189eccf71f.zip
Update: This version comes with mysql,msql,postgress and text drivers
Fixes: added USE="qt" makes GUI part optional
Diffstat (limited to 'dev-db/unixODBC')
-rw-r--r--dev-db/unixODBC/files/digest-unixODBC-2.0.61
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/unixODBC/files/digest-unixODBC-2.0.6 b/dev-db/unixODBC/files/digest-unixODBC-2.0.6
new file mode 100644
index 000000000000..21328339c1e9
--- /dev/null
+++ b/dev-db/unixODBC/files/digest-unixODBC-2.0.6
@@ -0,0 +1 @@
+MD5 4831ec89adba8765e73d936a2698df1a unixODBC-2.0.6.tar.gz
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
new file mode 100644
index 000000000000..2b222ab7e40d
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.1 2001/04/22 20:10:39 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="ODBC Interface for Linux"
+SRC_URI="http://www.unixodbc.org/${A}"
+HOMEPAGE="http://www.unixodbc.org"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-x11-2.3.0 )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" Makefile.orig > Makefile.in
+
+}
+src_compile() {
+ local myconf
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+ try ./configure --prefix=/usr --sysconfdir=/etc/unixODBC --host=${CHOST} ${myconf}
+
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
+}
+