summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2006-02-16 16:06:26 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2006-02-16 16:06:26 +0000
commitab84bd17cb99e0ef8a5e5805d4f53dd87b6aca50 (patch)
tree2fedb2c01c4d9ad11064e6b0e0e7dafd8cbe475c /dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild
parentnew fix for CVE-2005-3964 (diff)
downloadhistorical-ab84bd17cb99e0ef8a5e5805d4f53dd87b6aca50.tar.gz
historical-ab84bd17cb99e0ef8a5e5805d4f53dd87b6aca50.tar.bz2
historical-ab84bd17cb99e0ef8a5e5805d4f53dd87b6aca50.zip
Version bump
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild')
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild
new file mode 100644
index 000000000000..2e7c3ec1c4cb
--- /dev/null
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.1.ebuild,v 1.1 2006/02/16 16:06:26 sekretarz Exp $
+
+DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://libdbi-drivers.sourceforge.net/"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-db/libdbi-0.8.0
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite? ( <dev-db/sqlite-3 >=dev-db/sqlite-3 )
+ firebird? ( dev-db/firebird )"
+
+IUSE="mysql postgres sqlite oci8"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+SLOT=0
+
+src_compile() {
+ local myconf=""
+ local drivers=""
+# WARNING: the configure script does NOT work correctly
+# --without-$driver does NOT work
+# so do NOT use `use_with...`
+ use mysql && drivers="${drivers} mysql" myconf="${myconf} --with-mysql"
+ use postgres && drivers="${drivers} pgsql" myconf="${myconf} --with-pgsql"
+ use sqlite && drivers="${drivers} sqlite" myconf="${myconf} --with-sqlite"
+ use sqlite && drivers="${drivers} sqlite3" myconf="${myconf} --with-sqlite3"
+ use firebird && drivers="${drivers} firebird" myconf="${myconf} --with-firebird"
+ if use oci8; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ die "\$ORACLE_HOME is not set!"
+ fi
+ myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle" drivers="${drivers} oracle"
+ fi
+# safety check
+ if [ -z "${drivers}" ]; then
+ die "You have not specified any supported databases in your use flags (mysql, pgsql, sqlite, oracle, firebird)"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README README.osx TODO
+}