summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-09-09 11:56:21 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-09-09 11:56:21 +0000
commit1b646b082d066646e1a1d3f36b4946c7d4c5690d (patch)
treead1dbfd693242d1155087e67aba9a680ba62a146 /dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild
parentVersion bump to 0.6.1. Revision bump for the old version to distribute a plug... (diff)
downloadhistorical-1b646b082d066646e1a1d3f36b4946c7d4c5690d.tar.gz
historical-1b646b082d066646e1a1d3f36b4946c7d4c5690d.tar.bz2
historical-1b646b082d066646e1a1d3f36b4946c7d4c5690d.zip
Version bump; removed 2.11.0.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild
new file mode 100644
index 000000000000..cc37146bd364
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.12.0.ebuild,v 1.1 2005/09/09 11:56:21 ka0ttic Exp $
+
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+ dosed -i 's|^\(Cflags.*-I.* \)-I.*$|\1|' \
+ /usr/$(get_libdir)/pkgconfig/${MY_PN}-${SLOT}.pc
+
+ rm -fr ${D}/usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}