summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:47:23 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:47:23 +0000
commitf60b6b06624ce2075fb4437f9d574b510bf37108 (patch)
tree3f668de77e8fba016d715980079e43ec0d5d61a1 /dev-cpp/gconfmm
parentNew version for GNOME 2.28. Clean up old revision. (diff)
downloadhistorical-f60b6b06624ce2075fb4437f9d574b510bf37108.tar.gz
historical-f60b6b06624ce2075fb4437f9d574b510bf37108.tar.bz2
historical-f60b6b06624ce2075fb4437f9d574b510bf37108.zip
New version for GNOME 2.28.
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/gconfmm')
-rw-r--r--dev-cpp/gconfmm/ChangeLog8
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.0.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-cpp/gconfmm/ChangeLog b/dev-cpp/gconfmm/ChangeLog
index 2d45ac33be7d..b6c684f178fc 100644
--- a/dev-cpp/gconfmm/ChangeLog
+++ b/dev-cpp/gconfmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/gconfmm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.69 2009/10/12 20:31:30 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/ChangeLog,v 1.70 2009/10/29 22:44:45 eva Exp $
+
+*gconfmm-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gconfmm-2.28.0.ebuild:
+ New version for GNOME 2.28.
12 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org gconfmm-2.18.0.ebuild,
-gconfmm-2.20.0.ebuild:
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.0.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.0.ebuild
new file mode 100644
index 000000000000..d173af2a1e7f
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.28.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.28.0.ebuild,v 1.1 2009/10/29 22:44:45 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=gnome-base/gconf-2.4
+ >=dev-cpp/glibmm-2.12
+ >=dev-cpp/gtkmm-2.4"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ cd "${S}/docs/reference"
+ make all
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
+ cp -R examples "${D}/usr/share/doc/${PF}"
+ fi
+}