summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 21:59:21 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-08 21:59:21 +0000
commitd134c1c2f1424167f1fece53b91972c5c50f40ae (patch)
tree486a29b78e2a3f1ee33cc736a0e8316cede91148 /app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild
parentFixed libapreq2 dependency wrt bug #101329. (diff)
downloadhistorical-d134c1c2f1424167f1fece53b91972c5c50f40ae.tar.gz
historical-d134c1c2f1424167f1fece53b91972c5c50f40ae.tar.bz2
historical-d134c1c2f1424167f1fece53b91972c5c50f40ae.zip
Use hi def link rather than hi link. Bug #101788, bug #101804.
Package-Manager: portage-2.0.51.22-r2 flaming goat edition
Diffstat (limited to 'app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild')
-rw-r--r--app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild b/app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild
new file mode 100644
index 000000000000..b9d49266de15
--- /dev/null
+++ b/app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/xquery-syntax/xquery-syntax-0.1-r1.ebuild,v 1.1 2005/08/08 21:59:21 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: XQuery syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=803"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for XQuery.conf files."
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # use hi def link. Bug #101788, bug #101804.
+ sed -i -e 's,^hi link,hi def link,' syntax/xquery.vim || die "sed failed"
+}
+