summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-12 08:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-12 08:02:51 +0000
commitc5d62504a11221d64954b45b48dc7304055cdbfc (patch)
tree84d82db9a7a5760a41a38a9e67112a707f0cb4ae /app-text/wdiff
parentUpdate Copyright years (diff)
downloadhistorical-c5d62504a11221d64954b45b48dc7304055cdbfc.tar.gz
historical-c5d62504a11221d64954b45b48dc7304055cdbfc.tar.bz2
historical-c5d62504a11221d64954b45b48dc7304055cdbfc.zip
new diff tool
Diffstat (limited to 'app-text/wdiff')
-rw-r--r--app-text/wdiff/ChangeLog12
-rw-r--r--app-text/wdiff/files/digest-wdiff-0.52
-rw-r--r--app-text/wdiff/wdiff-0.5.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/app-text/wdiff/ChangeLog b/app-text/wdiff/ChangeLog
new file mode 100644
index 000000000000..f83fb3db2585
--- /dev/null
+++ b/app-text/wdiff/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-text/wdiff
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.1 2003/02/12 08:02:51 seemant Exp $
+
+*wdiff-0.5 (12 Feb 2003)
+
+ 12 Feb 2003; Seemant Kulleen <seemant@gentoo.org> wdiff-0.5.ebuild
+ ChangeLog files/digest-wdiff-0.5 :
+
+ New ebuild for diff'ing files without worrying about formatting.
+ Ebuild submission and patch (on the gentoo mirrors) creation by the
+ venerable Peter Simons <simons+gentoo@cryp.to> in bug #12511
diff --git a/app-text/wdiff/files/digest-wdiff-0.5 b/app-text/wdiff/files/digest-wdiff-0.5
new file mode 100644
index 000000000000..492c83e04f6c
--- /dev/null
+++ b/app-text/wdiff/files/digest-wdiff-0.5
@@ -0,0 +1,2 @@
+MD5 7f9c78f5dd6fb4f3dabe28fbd4d14319 wdiff-0.5.tar.gz 129267
+MD5 9a919e76ca95db105427d827ed1a4c31 wdiff-0.5-gentoo.diff.bz2 253
diff --git a/app-text/wdiff/wdiff-0.5.ebuild b/app-text/wdiff/wdiff-0.5.ebuild
new file mode 100644
index 000000000000..59c36d416bc9
--- /dev/null
+++ b/app-text/wdiff/wdiff-0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5.ebuild,v 1.1 2003/02/12 08:02:51 seemant Exp $
+
+inherit eutils
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Create a diff disregarding formatting"
+HOMEPAGE="http://www.gnu.org/software/wdiff/"
+SRC_URI="ftp://ftp.gnu.org/gnu/wdiff/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/libtermcap-compat
+ sys-apps/diffutils
+ sys-apps/less"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ # Cannot use econf here because the configure script that
+ # comes with wdiff is too old to understand the standard
+ # options.
+
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
+}