summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
committerMatthew Turk <satai@gentoo.org>2002-12-31 04:36:56 +0000
commit7990b28cad9969f099585d10517762f84aca16b1 (patch)
treeb998eb4a90edb6ff330ed17d890a8b9df865ece4 /app-text/sgml-common
parentNew SGML catalog eclass, hopefully will fix things. (diff)
downloadhistorical-7990b28cad9969f099585d10517762f84aca16b1.tar.gz
historical-7990b28cad9969f099585d10517762f84aca16b1.tar.bz2
historical-7990b28cad9969f099585d10517762f84aca16b1.zip
Oy. Tons of changes... Fixed all of these ebuilds to inherit from
sgml-catalog.eclass, and then set them all up to have proper dependencies on the newest items, as well as use the new, more robust installation and removal system. This will probably have some growing pains over the next few days, but the long range will be worth it. All problem hints will be found at http://www.gentoo.org/~satai/
Diffstat (limited to 'app-text/sgml-common')
-rw-r--r--app-text/sgml-common/ChangeLog8
-rw-r--r--app-text/sgml-common/files/digest-sgml-common-0.6.3-r31
-rw-r--r--app-text/sgml-common/sgml-common-0.6.3-r3.ebuild79
3 files changed, 87 insertions, 1 deletions
diff --git a/app-text/sgml-common/ChangeLog b/app-text/sgml-common/ChangeLog
index 9969d6ba6073..2d3f19937a32 100644
--- a/app-text/sgml-common/ChangeLog
+++ b/app-text/sgml-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sgml-common
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.10 2002/12/13 10:56:20 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/ChangeLog,v 1.11 2002/12/31 04:36:56 satai Exp $
+
+*sgml-common-0.6.3-r3 (30 Dec 2002)
+
+ 30 Dec 2002; Matthew Turk <satai@gentoo.org> :
+ Changed the echo's around a bit, other misc bits. Warrants a revision bump
+ just to make sure it gets caught with all the other SGML changes.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-text/sgml-common/files/digest-sgml-common-0.6.3-r3 b/app-text/sgml-common/files/digest-sgml-common-0.6.3-r3
new file mode 100644
index 000000000000..876e0934660f
--- /dev/null
+++ b/app-text/sgml-common/files/digest-sgml-common-0.6.3-r3
@@ -0,0 +1 @@
+MD5 103c9828f24820df86e55e7862e28974 sgml-common-0.6.3.tgz 76783
diff --git a/app-text/sgml-common/sgml-common-0.6.3-r3.ebuild b/app-text/sgml-common/sgml-common-0.6.3-r3.ebuild
new file mode 100644
index 000000000000..6ae34e202a8e
--- /dev/null
+++ b/app-text/sgml-common/sgml-common-0.6.3-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgml-common/sgml-common-0.6.3-r3.ebuild,v 1.1 2002/12/31 04:36:56 satai Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Base ISO character entities and utilities for SGML"
+SRC_URI="ftp://ftp.kde.org/pub/kde/devel/docbook/SOURCES/${P}.tgz
+ http://download.sourceforge.net/pub/mirrors/kde/devel/docbook/SOURCES/${P}.tgz"
+HOMEPAGE="http://www.iso.ch/cate/3524030.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc alpha"
+src_unpack() {
+
+ unpack ${A}
+ # We use a hacked version of install-catalog that supports the ROOT variable
+ cp ${FILESDIR}/${P}-install-catalog.in ${S}/bin
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ mandir=${D}/usr/share/man \
+ docdir=${D}/usr/share/doc \
+ install || die
+
+}
+
+pkg_postinst() {
+ if [ -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ einfo "Installing Catalogs..."
+ install-catalog --add \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog --add \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+ else
+ ewarn "install-catalog not found! Something went wrong!"
+ die
+ fi
+}
+
+pkg_prerm() {
+ cp /usr/bin/install-catalog ${T}
+}
+
+pkg_postrm() {
+ if [ ! -x "/usr/bin/install-catalog" ] && [ "$ROOT" = "/" ]
+ then
+ einfo "Removing Catalogs..."
+ if [ -e /etc/sgml/sgml-ent.cat ]
+ then
+ ${T}/install-catalog --remove \
+ /etc/sgml/sgml-ent.cat \
+ /usr/share/sgml/sgml-iso-entities-8879.1986/catalog
+ fi
+
+ if [ -e /etc/sgml/sgml-docbook.cat ]
+ then
+ ${T}/install-catalog --remove \
+ /etc/sgml/sgml-docbook.cat \
+ /etc/sgml/sgml-ent.cat
+ fi
+ fi
+}
+