summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-01-03 06:09:07 +0000
committerMatthew Turk <satai@gentoo.org>2003-01-03 06:09:07 +0000
commitf19b99ed844ae5a8da4d24499ecf7ab27db49511 (patch)
tree8b94af6e4904773824d9f328aed1f55946a771d1 /app-text/cook/cook-1.0.2.ebuild
parentClosing 10515 with patch from ferdy@ferdyx.org to convert HTML to (diff)
downloadhistorical-f19b99ed844ae5a8da4d24499ecf7ab27db49511.tar.gz
historical-f19b99ed844ae5a8da4d24499ecf7ab27db49511.tar.bz2
historical-f19b99ed844ae5a8da4d24499ecf7ab27db49511.zip
Another preprocessor, submitted by Jonathan Hunt. Closing 9944.
Diffstat (limited to 'app-text/cook/cook-1.0.2.ebuild')
-rw-r--r--app-text/cook/cook-1.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/cook/cook-1.0.2.ebuild b/app-text/cook/cook-1.0.2.ebuild
new file mode 100644
index 000000000000..75d0c3b57613
--- /dev/null
+++ b/app-text/cook/cook-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/cook/cook-1.0.2.ebuild,v 1.1 2003/01/03 06:09:07 satai Exp $
+
+DESCRIPTION="COOK is an embedded language which can be used as a macro preprocessor and for similar text processing."
+HOMEPAGE="http://cook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cook/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="sys-libs/glibc"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ cd ${S}
+ emake
+}
+
+src_install() {
+ cd ${S}
+ dodoc README doc/cook.txt doc/cook.html
+ dodir /usr/share/doc/${P}/example
+ cd ${S}/test
+ insinto /usr/share/doc/${P}/example
+ doins pcb.dbdef pcb.dg pcbprol.ps tempsens.pcb
+ cd ${S}
+ dobin src/cook
+}