summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-25 19:43:27 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-25 19:43:27 +0000
commit188371e0a9d2d31cdbfb97866e4e5c47ffb2d99c (patch)
treeb552ce47bce81cfd9cb5aec58946d8f3321fed47 /app-shells/sash/files
parentStarting with mesa-7.12 we'll need gles2 useflag, bug 383589 (diff)
downloadhistorical-188371e0a9d2d31cdbfb97866e4e5c47ffb2d99c.tar.gz
historical-188371e0a9d2d31cdbfb97866e4e5c47ffb2d99c.tar.bz2
historical-188371e0a9d2d31cdbfb97866e4e5c47ffb2d99c.zip
Drop useless fix-includes patch as this breaks with gcc-4.6+ (--disable-shared is not a valid flag). Depend on lib packages being built with USE=static-libs when we are built with USE=static #384333 by Guenther Brunthaler.
Package-Manager: portage-2.2.0_alpha59/cvs/Linux x86_64
Diffstat (limited to 'app-shells/sash/files')
-rw-r--r--app-shells/sash/files/sash-3.6-fix-includes.patch11
-rw-r--r--app-shells/sash/files/sash-3.6-readline.patch12
2 files changed, 5 insertions, 18 deletions
diff --git a/app-shells/sash/files/sash-3.6-fix-includes.patch b/app-shells/sash/files/sash-3.6-fix-includes.patch
deleted file mode 100644
index 3be0c0fcf589..000000000000
--- a/app-shells/sash/files/sash-3.6-fix-includes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ruN sash-3.6.orig/Makefile sash-3.6/Makefile
---- sash-3.6.orig/Makefile 2002-07-22 01:24:47.000000000 +0200
-+++ sash-3.6/Makefile 2003-10-17 14:25:00.306848712 +0200
-@@ -21,7 +21,7 @@
- -DHAVE_BSD_MOUNT=$(HAVE_BSD_MOUNT) \
- -DMOUNT_TYPE=$(MOUNT_TYPE)
-
--LDFLAGS = -static -s
-+LDFLAGS = --disable-shared -static -s
- LIBS = -lz
-
diff --git a/app-shells/sash/files/sash-3.6-readline.patch b/app-shells/sash/files/sash-3.6-readline.patch
index 2d2d2a4d51a8..79749e48f944 100644
--- a/app-shells/sash/files/sash-3.6-readline.patch
+++ b/app-shells/sash/files/sash-3.6-readline.patch
@@ -1,6 +1,5 @@
-diff -ruN sash-3.6/Makefile sash-3.6.readline/Makefile
---- sash-3.6/Makefile 2003-10-17 14:25:00.306848712 +0200
-+++ sash-3.6.readline/Makefile 2003-10-17 14:27:34.529403320 +0200
+--- sash-3.6/Makefile
++++ sash-3.6/Makefile
@@ -19,10 +19,11 @@
-DHAVE_LINUX_ATTR=$(HAVE_LINUX_ATTR) \
-DHAVE_LINUX_MOUNT=$(HAVE_LINUX_MOUNT) \
@@ -9,15 +8,14 @@ diff -ruN sash-3.6/Makefile sash-3.6.readline/Makefile
+ -DMOUNT_TYPE=$(MOUNT_TYPE) \
+ -DHAVE_READLINE
- LDFLAGS = --disable-shared -static -s
+ LDFLAGS = -static -s
-LIBS = -lz
+LIBS = -lz -lreadline -lncurses
BINDIR = /bin
-diff -ruN sash-3.6/sash.c sash-3.6.readline/sash.c
---- sash-3.6/sash.c 2002-07-22 00:55:28.000000000 +0200
-+++ sash-3.6.readline/sash.c 2003-10-17 14:26:26.184793280 +0200
+--- sash-3.6/sash.c
++++ sash-3.6/sash.c
@@ -384,6 +384,201 @@
static void usage(void);
static Alias * findAlias(const char * name);