summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-09 00:13:25 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-09 00:13:25 +0000
commit20a31a56fe08ec788eb3d2371f68f894af189fd6 (patch)
tree59834e4cdcb21688be1098634f80623e6d1e4ffb /app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
parentold (diff)
downloadhistorical-20a31a56fe08ec788eb3d2371f68f894af189fd6.tar.gz
historical-20a31a56fe08ec788eb3d2371f68f894af189fd6.tar.bz2
historical-20a31a56fe08ec788eb3d2371f68f894af189fd6.zip
Fix config file naming #169968 by Ali Polatel.
Package-Manager: portage-2.1.2.1-r1
Diffstat (limited to 'app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild')
-rw-r--r--app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild b/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
new file mode 100644
index 000000000000..d777369291c1
--- /dev/null
+++ b/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sandboxshell/sandboxshell-0.3-r3.ebuild,v 1.1 2007/03/09 00:13:25 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="launch a sandboxed shell ... useful for debugging ebuilds"
+HOMEPAGE="http://wh0rd.org/"
+SRC_URI=""
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+# Portage 2.1.1 changes the /var/tmp/portage structure from <pkg> to <cat>/<pkg>
+RDEPEND=">sys-apps/portage-2.1.1
+ app-shells/bash"
+
+S=${WORKDIR}
+
+src_install() {
+ dobin "${FILESDIR}"/sandboxshell || die
+ doman "${FILESDIR}"/sandboxshell.1
+ insinto /etc
+ newins "${FILESDIR}"/sandboxshell-r1.conf sandboxshell.conf
+ make_desktop_entry /usr/bin/sandboxshell
+}