summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-17 11:30:05 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-17 11:30:05 +0000
commit30e7d49a8ccb48f4a37236c3adf2e58374a5171d (patch)
tree6c03baa3aeb41d13a2d5069c12cf2f66117797f9 /app-shells/ash
parentcompressed patch added (diff)
downloadhistorical-30e7d49a8ccb48f4a37236c3adf2e58374a5171d.tar.gz
historical-30e7d49a8ccb48f4a37236c3adf2e58374a5171d.tar.bz2
historical-30e7d49a8ccb48f4a37236c3adf2e58374a5171d.zip
Added patch so ash will build with gcc-4.
Diffstat (limited to 'app-shells/ash')
-rw-r--r--app-shells/ash/ChangeLog6
-rw-r--r--app-shells/ash/Manifest15
-rw-r--r--app-shells/ash/ash-1.6.ebuild5
-rw-r--r--app-shells/ash/files/ash-1.6-gcc4.diff8
4 files changed, 30 insertions, 4 deletions
diff --git a/app-shells/ash/ChangeLog b/app-shells/ash/ChangeLog
index 86e098ce5189..0074ca28df79 100644
--- a/app-shells/ash/ChangeLog
+++ b/app-shells/ash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/ash
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ChangeLog,v 1.15 2005/04/24 03:05:56 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ChangeLog,v 1.16 2005/05/17 11:30:05 ka0ttic Exp $
+
+ 17 May 2005; Aaron Walker <ka0ttic@gentoo.org> +files/ash-1.6-gcc4.diff,
+ ash-1.6.ebuild:
+ Added patch so ash will build with gcc-4.
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> ash-1.6.ebuild:
Stable on ppc.
diff --git a/app-shells/ash/Manifest b/app-shells/ash/Manifest
index fbc3084a9fb7..bd87cc04a1a2 100644
--- a/app-shells/ash/Manifest
+++ b/app-shells/ash/Manifest
@@ -1,3 +1,14 @@
-MD5 2b27a030a23c83e824cccf63e246a024 ash-1.6.ebuild 1409
-MD5 4b772c82ef66d4869d6cfbd275364736 ChangeLog 1698
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 b10c57387934895b435db8fd22fa7639 ash-1.6.ebuild 1455
+MD5 5a5f4928132f5346218fab158871be66 ChangeLog 1837
+MD5 c9c7e478fdca81cc11c51dc17bd6afc9 files/ash-1.6-gcc4.diff 234
MD5 8ae8baf7eab9f0bf48c73e3198ab0ee4 files/digest-ash-1.6 127
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCidYSEZCkKN40op4RAiufAJ9/VxKqGzV83gm2+kw3EqHurToD2QCeOYLw
+BH0maMJ4J97zJId7i7pjl5k=
+=j49l
+-----END PGP SIGNATURE-----
diff --git a/app-shells/ash/ash-1.6.ebuild b/app-shells/ash/ash-1.6.ebuild
index 5920cebf4a9a..040d88fdc405 100644
--- a/app-shells/ash/ash-1.6.ebuild
+++ b/app-shells/ash/ash-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.18 2005/04/24 03:05:56 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.19 2005/05/17 11:30:05 ka0ttic Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -26,6 +26,9 @@ src_unpack() {
(cd ${WORKDIR}/bin_NetBSD-1.6release; tar zxv --no-same-owner \
-f ${DISTDIR}/bin.tar.gz src/bin/sh)
epatch ${DISTDIR}/dash-ash-hetio-yacc.diff.bz2
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.diff
}
src_compile() {
diff --git a/app-shells/ash/files/ash-1.6-gcc4.diff b/app-shells/ash/files/ash-1.6-gcc4.diff
new file mode 100644
index 000000000000..c6334e90115e
--- /dev/null
+++ b/app-shells/ash/files/ash-1.6-gcc4.diff
@@ -0,0 +1,8 @@
+--- hetio.h.orig 2005-05-17 03:51:59.000000000 -0400
++++ hetio.h 2005-05-17 03:52:02.000000000 -0400
+@@ -19,4 +19,4 @@
+ int hetio_read_input(int fd);
+ void hetio_reset_term(void);
+
+-extern int hetio_inter;
++//extern int hetio_inter;