summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-13 21:25:07 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-13 21:25:07 +0000
commitff8f8cb12325547689c11903d247b5187eed7d5b (patch)
tree7bc6cc84e41ea388694af793dd212c3072391ae9 /app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild
parentRemove obsolete version. Fix the as-needed patch (#140255). (diff)
downloadhistorical-ff8f8cb12325547689c11903d247b5187eed7d5b.tar.gz
historical-ff8f8cb12325547689c11903d247b5187eed7d5b.tar.bz2
historical-ff8f8cb12325547689c11903d247b5187eed7d5b.zip
Version bump. Removed slang.h header include and replaced it with the single 'offsetof' macro that it needed. Cleaned up old versions. (#135060)
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild')
-rw-r--r--app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild b/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild
new file mode 100644
index 000000000000..82ca9d9aeb76
--- /dev/null
+++ b/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-libsynce/synce-libsynce-0.9.2.ebuild,v 1.1 2006/07/13 21:25:07 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="Common Library for Synce (connecting WinCE devices to Linux)"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="" # dbus
+
+DEPEND=">=dev-libs/check-0.8.3.1"
+# dbus? ( sys-apps/dbus )"
+
+S=${WORKDIR}/libsynce-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.9.1-amd64.patch
+ sed -i -e 's/#include <slang.h>/#ifndef offsetof\n#define offsetof(T,F) ((unsigned int)((char *)\&((T *)0L)->F - (char *)0L))\n#endif/' lib/synce_socket.c
+}
+
+src_compile() {
+ # dbus support not quite there yet.
+ econf # $(use_enable dbus)
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README
+}