summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-04-17 22:26:37 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-04-17 22:26:37 +0000
commit13f1fd6c2d64a003098b426ae531f91956e4177d (patch)
tree4fbb4065fa5eeb40022d6eb2557f9c743f1d2ddc /app-office
parentdebug fixy thingy (diff)
downloadhistorical-13f1fd6c2d64a003098b426ae531f91956e4177d.tar.gz
historical-13f1fd6c2d64a003098b426ae531f91956e4177d.tar.bz2
historical-13f1fd6c2d64a003098b426ae531f91956e4177d.zip
debug fixy thingy
Diffstat (limited to 'app-office')
-rw-r--r--app-office/oooqs/Manifest2
-rw-r--r--app-office/oooqs/files/oooqs-debug.patch15
-rw-r--r--app-office/oooqs/oooqs-1.0_rc3.ebuild10
3 files changed, 24 insertions, 3 deletions
diff --git a/app-office/oooqs/Manifest b/app-office/oooqs/Manifest
index 03e819f576e9..cb781ca4e417 100644
--- a/app-office/oooqs/Manifest
+++ b/app-office/oooqs/Manifest
@@ -1,4 +1,4 @@
-MD5 c360d1f570edb812002e0728848e11e8 oooqs-1.0_rc3.ebuild 583
+MD5 2ddad295e3efd17240d39cc4e4d966fa oooqs-1.0_rc3.ebuild 582
MD5 449d296acfbfbc4a250c2951278ab97d ChangeLog 395
MD5 259ec7b89b16f4a1b616951ebfa38ee7 files/digest-oooqs-1.0_rc3 65
MD5 cebd3549322f47de78aba8649828f420 files/oooqs-debug.patch 683
diff --git a/app-office/oooqs/files/oooqs-debug.patch b/app-office/oooqs/files/oooqs-debug.patch
new file mode 100644
index 000000000000..f292534aba04
--- /dev/null
+++ b/app-office/oooqs/files/oooqs-debug.patch
@@ -0,0 +1,15 @@
+--- oooqs/oooqs.cpp.orig 2003-04-17 18:20:15.000000000 -0400
++++ oooqs/oooqs.cpp 2003-04-17 18:20:26.000000000 -0400
+@@ -484,9 +484,9 @@
+ }
+ KProcess* process = new KProcess;
+ *process << soffice << params;
+- for ( QStringList::Iterator it = params.begin(); it != params.end(); ++it ) {
+- KMessageBox::information(this, *it);
+- }
++// for ( QStringList::Iterator it = params.begin(); it != params.end(); ++it ) {
++// KMessageBox::information(this, *it);
++// }
+ /** the exit Handler only works, if the father ist notified */
+ process->start(KProcess::NotifyOnExit,KProcess::NoCommunication);
+ connect( process, SIGNAL (processExited(KProcess*)), SLOT (delProcess(KProcess*)));
diff --git a/app-office/oooqs/oooqs-1.0_rc3.ebuild b/app-office/oooqs/oooqs-1.0_rc3.ebuild
index 34d77215ae8a..7f269c0af7d4 100644
--- a/app-office/oooqs/oooqs-1.0_rc3.ebuild
+++ b/app-office/oooqs/oooqs-1.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/oooqs-1.0_rc3.ebuild,v 1.2 2003/02/13 09:18:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/oooqs-1.0_rc3.ebuild,v 1.3 2003/04/17 22:26:31 sethbc Exp $
inherit kde-base
need-kde 3
@@ -12,5 +12,11 @@ DESCRIPTION="OpenOffice.org Quickstarter, runs in the KDE SystemTray."
SRC_URI="http://download.berlios.de/segfaultskde/${P}.tar.gz"
HOMEPAGE="http://segfaultskde.berlios.de/index.php"
LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="x86"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/oooqs-debug.patch
+
+}