summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 18:19:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 18:19:29 +0000
commitde1296ec1832e6eb089ecc22b00658795f7d144c (patch)
treed2ccaed365e7e6d82df78cadd232e78725f8dae4 /app-office/kword
parentStable on hppa (diff)
downloadhistorical-de1296ec1832e6eb089ecc22b00658795f7d144c.tar.gz
historical-de1296ec1832e6eb089ecc22b00658795f7d144c.tar.bz2
historical-de1296ec1832e6eb089ecc22b00658795f7d144c.zip
Version bump
Package-Manager: portage-2.1.2_rc2-r3
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/files/digest-kword-1.6.13
-rw-r--r--app-office/kword/kword-1.6.1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 59e12f0b0566..2f24163acfd4 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.78 2006/12/01 01:50:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.79 2006/12/01 18:19:29 flameeyes Exp $
+
+*kword-1.6.1 (01 Dec 2006)
+
+ 01 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +kword-1.6.1.ebuild:
+ Version bump
01 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
-files/post-1.3-koffice-CAN-2005-3193.diff,
diff --git a/app-office/kword/files/digest-kword-1.6.1 b/app-office/kword/files/digest-kword-1.6.1
new file mode 100644
index 000000000000..8296a0484c60
--- /dev/null
+++ b/app-office/kword/files/digest-kword-1.6.1
@@ -0,0 +1,3 @@
+MD5 f7b90b46b79019edc60761a6bff2d387 koffice-1.6.1.tar.bz2 56999028
+RMD160 ee4fa84a53f92035c0ab9427e0acb18feca701db koffice-1.6.1.tar.bz2 56999028
+SHA256 5505a6c54009dd0cb75a3770c3daa476154958f92692ca0748b1842d9cd6e728 koffice-1.6.1.tar.bz2 56999028
diff --git a/app-office/kword/kword-1.6.1.ebuild b/app-office/kword/kword-1.6.1.ebuild
new file mode 100644
index 000000000000..b6c164e9772c
--- /dev/null
+++ b/app-office/kword/kword-1.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6.1.ebuild,v 1.1 2006/12/01 18:19:29 flameeyes Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}