summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:44:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-19 16:44:12 +0000
commitc9712d46a689537205e45452b87f3641493f5bbd (patch)
tree8836adb2b0d3606f59b56cac94f6eaa9223ed4e6 /app-office/kword
parentm68k love (diff)
downloadhistorical-c9712d46a689537205e45452b87f3641493f5bbd.tar.gz
historical-c9712d46a689537205e45452b87f3641493f5bbd.tar.bz2
historical-c9712d46a689537205e45452b87f3641493f5bbd.zip
Update to 1.6.0 final.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog8
-rw-r--r--app-office/kword/files/digest-kword-1.6.03
-rw-r--r--app-office/kword/kword-1.6.0.ebuild57
3 files changed, 67 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 56725fba2040..56263f050ee9 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kword
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.75 2006/10/17 20:30:26 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.76 2006/10/19 16:44:12 flameeyes Exp $
+
+*kword-1.6.0 (19 Oct 2006)
+
+ 19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -kword-1.6_beta1.ebuild, -kword-1.6_rc1.ebuild, +kword-1.6.0.ebuild:
+ Update to 1.6.0 final.
17 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> kword-1.5.2.ebuild:
Stable on Alpha.
diff --git a/app-office/kword/files/digest-kword-1.6.0 b/app-office/kword/files/digest-kword-1.6.0
new file mode 100644
index 000000000000..2e01d4cedd36
--- /dev/null
+++ b/app-office/kword/files/digest-kword-1.6.0
@@ -0,0 +1,3 @@
+MD5 e669cf19b2e1c7db7029c0772c527c0d koffice-1.6.0.tar.bz2 56718478
+RMD160 be09c18005eb33f6dc35ab0359cc97a8a658ce7c koffice-1.6.0.tar.bz2 56718478
+SHA256 9eddaae640ada9bd184f001e2489854daf7094b73e5f15b0b8deffb4cc654ae2 koffice-1.6.0.tar.bz2 56718478
diff --git a/app-office/kword/kword-1.6.0.ebuild b/app-office/kword/kword-1.6.0.ebuild
new file mode 100644
index 000000000000..fead2a07a491
--- /dev/null
+++ b/app-office/kword/kword-1.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6.0.ebuild,v 1.1 2006/10/19 16:44:12 flameeyes Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}