summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:54:11 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:54:11 +0000
commitacf9519497f81381784f84e8883ba1341d881258 (patch)
tree55c394fafd2d4707eb2c39b26e2243f8603344a8 /app-office/kword
parentppc stable, bug #145714 (diff)
downloadhistorical-acf9519497f81381784f84e8883ba1341d881258.tar.gz
historical-acf9519497f81381784f84e8883ba1341d881258.tar.bz2
historical-acf9519497f81381784f84e8883ba1341d881258.zip
Version bump.
Package-Manager: portage-2.1.1
Diffstat (limited to 'app-office/kword')
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/files/digest-kword-1.6_beta13
-rw-r--r--app-office/kword/kword-1.6_beta1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index b502069a0ca1..a1b0ed7e1db9 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.66 2006/09/07 14:19:44 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.67 2006/09/15 18:50:49 carlo Exp $
+
+*kword-1.6_beta1 (15 Sep 2006)
+
+ 15 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +kword-1.6_beta1.ebuild:
+ Version bump.
07 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org> kword-1.5.1.ebuild:
Stable on sparc
diff --git a/app-office/kword/files/digest-kword-1.6_beta1 b/app-office/kword/files/digest-kword-1.6_beta1
new file mode 100644
index 000000000000..a68717744650
--- /dev/null
+++ b/app-office/kword/files/digest-kword-1.6_beta1
@@ -0,0 +1,3 @@
+MD5 c7aeaf362210ff2e52d610bdbe2c91fd koffice-1.5.91.tar.bz2 54138646
+RMD160 8b412a4d6199cec32fd4a43660abb1352d675dd4 koffice-1.5.91.tar.bz2 54138646
+SHA256 2e1cbd20c8201a9d2d4c14fa4184b112d90a8f8bb089915f4d748eb9f8cef7aa koffice-1.5.91.tar.bz2 54138646
diff --git a/app-office/kword/kword-1.6_beta1.ebuild b/app-office/kword/kword-1.6_beta1.ebuild
new file mode 100644
index 000000000000..2c27b3783136
--- /dev/null
+++ b/app-office/kword/kword-1.6_beta1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-1.6_beta1.ebuild,v 1.1 2006/09/15 18:50:49 carlo Exp $
+
+KMNAME=koffice
+MAXKOFFICEVER=${PV}
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice word processor."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ $(deprange $PV $MAXKOFFICEVER app-office/kspread)
+ >=app-text/wv2-0.1.8
+ >=media-gfx/imagemagick-5.5.2
+ >=app-text/libwpd-0.8.2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkspreadcommon kspread"
+
+KMEXTRACTONLY="
+ lib/
+ kspread/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/kword"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile libs first
+ echo "SUBDIRS = liboofilter kword" > $S/filters/Makefile.am
+
+ for i in $(find ${S}/lib -iname "*\.ui"); do
+ ${QTDIR}/bin/uic ${i} > ${i%.ui}.h
+ done
+
+ kde-meta_src_unpack makefiles
+}