summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-11-22 16:22:38 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-11-22 16:22:38 +0000
commit96557dc597cc232f73965edd6e29b41945771b8b (patch)
tree8ca2a1ab84231ff1cb2573b5aa47ef5b63211ecb /app-office/koffice-l10n
parentMake okteta actualy functional. Per bug #292608. (diff)
downloadhistorical-96557dc597cc232f73965edd6e29b41945771b8b.tar.gz
historical-96557dc597cc232f73965edd6e29b41945771b8b.tar.bz2
historical-96557dc597cc232f73965edd6e29b41945771b8b.zip
Version bump
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'app-office/koffice-l10n')
-rw-r--r--app-office/koffice-l10n/ChangeLog8
-rw-r--r--app-office/koffice-l10n/koffice-l10n-2.1.0.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/app-office/koffice-l10n/ChangeLog b/app-office/koffice-l10n/ChangeLog
index d184a95417c3..2f2883bf2c8e 100644
--- a/app-office/koffice-l10n/ChangeLog
+++ b/app-office/koffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.6 2009/08/12 10:16:06 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.7 2009/11/22 16:14:19 tampakrap Exp $
+
+*koffice-l10n-2.1.0 (22 Nov 2009)
+
+ 22 Nov 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +koffice-l10n-2.1.0.ebuild:
+ version bump
12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
-koffice-l10n-2.0.0.ebuild, -koffice-l10n-2.0.1.ebuild:
diff --git a/app-office/koffice-l10n/koffice-l10n-2.1.0.ebuild b/app-office/koffice-l10n/koffice-l10n-2.1.0.ebuild
new file mode 100644
index 000000000000..64770473915f
--- /dev/null
+++ b/app-office/koffice-l10n/koffice-l10n-2.1.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/koffice-l10n-2.1.0.ebuild,v 1.1 2009/11/22 16:14:19 tampakrap Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca da de el en_GB es et fr fy gl hne it ja kk nb nds nl pl pt pt_BR
+ sv tr uk wa zh_CN zh_TW"
+URI_BASE="mirror://kde/unstable/koffice-${PV}/src/${PN}/"
+SRC_URI=""
+SLOT="2"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs} -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)"
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}