summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-11-06 12:13:30 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-11-06 12:13:30 +0000
commit15c0c307d58893ca4253c6635546d7a6ee1addef (patch)
tree52f107e3dce1d47c7da6baaa3fb9a79bea35f234 /app-office/facturalux
parentAdding omni 1.6 (diff)
downloadhistorical-15c0c307d58893ca4253c6635546d7a6ee1addef.tar.gz
historical-15c0c307d58893ca4253c6635546d7a6ee1addef.tar.bz2
historical-15c0c307d58893ca4253c6635546d7a6ee1addef.zip
Initial import. Closes bug #20503.
Diffstat (limited to 'app-office/facturalux')
-rw-r--r--app-office/facturalux/ChangeLog10
-rw-r--r--app-office/facturalux/Manifest5
-rw-r--r--app-office/facturalux/facturalux-0.4.ebuild60
-rw-r--r--app-office/facturalux/files/digest-facturalux-0.42
-rw-r--r--app-office/facturalux/files/facturalux-0.4-gentoo.patch40
-rw-r--r--app-office/facturalux/files/facturalux-base-0.0-gentoo.patch97
6 files changed, 214 insertions, 0 deletions
diff --git a/app-office/facturalux/ChangeLog b/app-office/facturalux/ChangeLog
new file mode 100644
index 000000000000..d70e0dd3643e
--- /dev/null
+++ b/app-office/facturalux/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-office/facturalux
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/facturalux/ChangeLog,v 1.1 2003/11/06 12:13:11 brandy Exp $
+
+*facturalux-0.4 (07 Nov 2003)
+
+ 07 Nov 2003; Brandy Westcott brandy@gentoo.org facturalux-0.4.ebuild:
+ Initial import. Thanks to Miguel Revilla Rodríguez <yo@miguelrevilla.com> for
+ providing the ebuild template. Closes bug #20503.
+
diff --git a/app-office/facturalux/Manifest b/app-office/facturalux/Manifest
new file mode 100644
index 000000000000..e6b3e87f13cd
--- /dev/null
+++ b/app-office/facturalux/Manifest
@@ -0,0 +1,5 @@
+MD5 5d190a095fee4c43f45be947c3efc42d facturalux-0.4.ebuild 1355
+MD5 65c807581c66ce3ed58964d04fc6a3e5 ChangeLog 460
+MD5 3364b5f5a39640c81b871eb91173ff75 files/facturalux-0.4-gentoo.patch 2042
+MD5 8cc773b781c5ea9afc0bedc6a8a7500b files/facturalux-base-0.0-gentoo.patch 3416
+MD5 6f37b351d44e9d4cd4a1cbe8d05be6dc files/digest-facturalux-0.4 145
diff --git a/app-office/facturalux/facturalux-0.4.ebuild b/app-office/facturalux/facturalux-0.4.ebuild
new file mode 100644
index 000000000000..60fcf456b6b0
--- /dev/null
+++ b/app-office/facturalux/facturalux-0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/facturalux/facturalux-0.4.ebuild,v 1.1 2003/11/06 12:13:11 brandy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="General purpose ERP/CRM software"
+HOMEPAGE="http://www.facturalux.org"
+SRC_URI="mirror://sourceforge/facturalux/${P}.tar.bz2
+ mirror://sourceforge/facturalux/personalizacion-base-0.0.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/qt-3
+ sys-libs/zlib"
+RDEPEND="dev-db/postgresql"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${PN}-base-0.0-gentoo.patch
+
+}
+
+src_compile() {
+
+ cd ${S}
+ econf || die "configure failed"
+ emake || die "parallel make failed"
+ cd ${WORKDIR}/base-0.0
+ econf || die "base-0.0 configure failed"
+ emake || die "base-0.0 parallel make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "install failed"
+ cd ${WORKDIR}/base-0.0
+ make DESTDIR=${D} install || die "base-0.0 install failed"
+
+ cd ${S}
+ dodoc AUTHORS ChangeLog COPYING INSTALL LEEME NOTES README TODO
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "You must create a new database and a proper user:"
+ einfo
+ einfo "# su postgres"
+ einfo "$ createdb -E UNICODE facturalux"
+ einfo "$ createuser --pwprompt password"
+ einfo
+
+}
diff --git a/app-office/facturalux/files/digest-facturalux-0.4 b/app-office/facturalux/files/digest-facturalux-0.4
new file mode 100644
index 000000000000..b6d8790b35fc
--- /dev/null
+++ b/app-office/facturalux/files/digest-facturalux-0.4
@@ -0,0 +1,2 @@
+MD5 63191c7c87d5ba29c9585f5c568e1ba3 facturalux-0.4.tar.bz2 1124447
+MD5 36868bdcb79eecd1eb3a497164f9ab9e personalizacion-base-0.0.tar.bz2 490579
diff --git a/app-office/facturalux/files/facturalux-0.4-gentoo.patch b/app-office/facturalux/files/facturalux-0.4-gentoo.patch
new file mode 100644
index 000000000000..d800cf5b0cc7
--- /dev/null
+++ b/app-office/facturalux/files/facturalux-0.4-gentoo.patch
@@ -0,0 +1,40 @@
+diff -ur facturalux-0.4/facturalux/docs/Makefile.in facturalux-0.4-gentoo/facturalux/docs/Makefile.in
+--- facturalux-0.4/facturalux/docs/Makefile.in 2002-12-19 10:17:25.000000000 +1300
++++ facturalux-0.4-gentoo/facturalux/docs/Makefile.in 2003-11-07 00:18:13.000000000 +1300
+@@ -384,10 +384,10 @@
+ install-data-local:
+ #>- $(mkinstalldirs) $(datadir)/doc/facturalux/
+ #>+ 1
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/doc/facturalux/
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/doc/facturalux-$(VERSION)/html
+ #>- $(INSTALL_DATA) $(srcdir)/index.html $(datadir)/doc/facturalux/index.html
+ #>+ 1
+- $(INSTALL_DATA) $(srcdir)/index.html $(DESTDIR)$(datadir)/doc/facturalux/index.html
++ $(INSTALL_DATA) $(srcdir)/index.html $(DESTDIR)$(datadir)/doc/facturalux-$(VERSION)/html/index.html
+
+ uninstall-local:
+ #>- -rm -f $(datadir)/doc/facturalux/index.html
+diff -ur facturalux-0.4/facturalux/flbase/FLApplication.cpp facturalux-0.4-gentoo/facturalux/flbase/FLApplication.cpp
+--- facturalux-0.4/facturalux/flbase/FLApplication.cpp 2002-12-19 10:17:25.000000000 +1300
++++ facturalux-0.4-gentoo/facturalux/flbase/FLApplication.cpp 2003-11-07 00:19:43.000000000 +1300
+@@ -366,7 +366,7 @@
+ }
+ }
+ }
+- QString index = FLDATA "/doc/facturalux/index.html";
++ QString index = FLDATA "/doc/facturalux-0.4/html/index.html";
+ HelpWindow *help = new HelpWindow (index, ".", pWorkspace, "help viewer");
+
+ help->showMaximized ();
+diff -ur facturalux-0.4/facturalux/kugar/mreportsection.cpp facturalux-0.4-gentoo/facturalux/kugar/mreportsection.cpp
+--- facturalux-0.4/facturalux/kugar/mreportsection.cpp 2002-12-19 10:17:25.000000000 +1300
++++ facturalux-0.4-gentoo/facturalux/kugar/mreportsection.cpp 2003-11-06 18:09:44.000000000 +1300
+@@ -200,7 +200,7 @@
+
+ /** Sets the data for the all calculated fields - list size must number of calculated fields */
+ void
+-MReportSection::setCalcFieldData (QPtrList < QMemArray < double >>*values)
++MReportSection::setCalcFieldData (QPtrList < QMemArray < double > >*values)
+ {
+ MCalcObject *field;
+ int i = 0;
diff --git a/app-office/facturalux/files/facturalux-base-0.0-gentoo.patch b/app-office/facturalux/files/facturalux-base-0.0-gentoo.patch
new file mode 100644
index 000000000000..1d67e5242b89
--- /dev/null
+++ b/app-office/facturalux/files/facturalux-base-0.0-gentoo.patch
@@ -0,0 +1,97 @@
+diff -ur base-0.0/base/process/Makefile.in base-0.0-gentoo/base/process/Makefile.in
+--- base-0.0/base/process/Makefile.in 2002-12-19 10:21:12.000000000 +1300
++++ base-0.0-gentoo/base/process/Makefile.in 2003-11-06 19:12:39.000000000 +1300
+@@ -243,9 +243,9 @@
+ ####### kdevelop will overwrite this part!!! (begin)##########
+ lib_LTLIBRARIES = libprocess.la
+
+-INCLUDES = $(all_includes)
++INCLUDES = $(all_includes) -I${S}/facturalux/flbase -I${S}/facturalux/plugins/flfielddb -I${S}/facturalux/plugins/fltabledb -I${S}/facturalux/barcode -I${S}/facturalux/kugar -I${S}/facturalux/process
+
+-LDFLAGS =
++LDFLAGS =
+
+ libprocess_la_LDFLAGS = -version-info 0:0:0
+
+diff -ur base-0.0/configure base-0.0-gentoo/configure
+--- base-0.0/configure 2002-12-06 07:38:15.000000000 +1300
++++ base-0.0-gentoo/configure 2003-11-06 18:44:27.000000000 +1300
+@@ -22349,75 +22349,9 @@
+
+
+
+-save_LDFLAGS=$LDFLAGS
+-LDFLAGS="-L${libdir} $X_LDFLAGS $QT_LDFLAGS $LDFLAGS"
+-echo "$as_me:$LINENO: checking for main in -lflbase" >&5
+-echo $ECHO_N "checking for main in -lflbase... $ECHO_C" >&6
+-if test "${ac_cv_lib_flbase_main+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lflbase $LIBQT -lqui -lkugar -lbarcode -lprocess $LIBS"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-#include "confdefs.h"
+-
+-
+-#ifdef F77_DUMMY_MAIN
+-# ifdef __cplusplus
+- extern "C"
+-# endif
+- int F77_DUMMY_MAIN() { return 1; }
+-#endif
+-int
+-main ()
+-{
+-main ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_lib_flbase_main=yes
+-else
+- echo "$as_me: failed program was:" >&5
+-cat conftest.$ac_ext >&5
+-ac_cv_lib_flbase_main=no
+-fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_lib_flbase_main" >&5
+-echo "${ECHO_T}$ac_cv_lib_flbase_main" >&6
+-if test $ac_cv_lib_flbase_main = yes; then
+- fllib=${libdir}
+-else
+- fllib=NO
+-fi
+-
+-if test $fllib = NO
+-then
+- { { echo "$as_me:$LINENO: error: your system fails at linking a small FacturaLUX application!
+-Check, if your compiler and FacturaLUX are installed correctly.
+-For more details about this problem, look at the end of config.log." >&5
+-echo "$as_me: error: your system fails at linking a small FacturaLUX application!
+-Check, if your compiler and FacturaLUX are installed correctly.
+-For more details about this problem, look at the end of config.log." >&2;}
+- { (exit 1); exit 1; }; }
+-fi
+-LDFLAGS="-L${fllib} -L${fllib}/designer $save_LDFLAGS"
+-CXXFLAGS="-I${prefix}/include/facturalux $CXXFLAGS"
++#LIBS="-lflbase $LIBQT -lqui -lkugar -lbarcode -lprocess $LIBS"
++#LDFLAGS="-L${fllib} -L${fllib}/designer $save_LDFLAGS"
++#CXXFLAGS="-I${S}/facturalux/flbase $CXXFLAGS"
+
+ ac_config_files="$ac_config_files Makefile base/Makefile base/forms/Makefile base/process/Makefile base/icons/Makefile base/queries/Makefile base/reports/Makefile base/tables/Makefile base/translations/Makefile"
+ cat >confcache <<\_ACEOF