summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-05 02:34:01 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-05 02:34:01 +0000
commit16a6841758363aa7a4eeec9cbc0f9a4dd8b52174 (patch)
tree407805c180f4db9d0adc900850d2f824c62be5ed /app-misc/gwine/gwine-0.10.3.ebuild
parentCleanup more packaging crap that gwine bundles #169370 by Fatal1ty. (diff)
downloadhistorical-16a6841758363aa7a4eeec9cbc0f9a4dd8b52174.tar.gz
historical-16a6841758363aa7a4eeec9cbc0f9a4dd8b52174.tar.bz2
historical-16a6841758363aa7a4eeec9cbc0f9a4dd8b52174.zip
Version bump.
Package-Manager: portage-2.1.2-r14
Diffstat (limited to 'app-misc/gwine/gwine-0.10.3.ebuild')
-rw-r--r--app-misc/gwine/gwine-0.10.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/gwine/gwine-0.10.3.ebuild b/app-misc/gwine/gwine-0.10.3.ebuild
new file mode 100644
index 000000000000..0a779a3a5133
--- /dev/null
+++ b/app-misc/gwine/gwine-0.10.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gwine/gwine-0.10.3.ebuild,v 1.1 2007/03/05 02:34:01 vapier Exp $
+
+inherit eutils gnome2 perl-app
+
+DESCRIPTION="Gnome application to manage your wine cellar"
+HOMEPAGE="http://home.gna.org/gwine/"
+SRC_URI="http://download.gna.org/gwine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.0
+ >=dev-perl/glib-perl-0.90
+ >=dev-perl/gtk2-perl-0.90
+ >=dev-perl/gnome2-perl-1.021
+ >=dev-perl/gtk2-gladexml-1.003
+ dev-perl/gnome2-gconf
+ dev-perl/libintl-perl
+ dev-perl/DateTime"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.10.3-package.patch
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ gnome2_gconf_install
+}