summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-30 23:37:30 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-30 23:37:30 +0000
commitdbc9d9a0009b77dce57c2dc25ab4e4415c5cbdc0 (patch)
treec93e42218c2072eec45849568157ccac7d0f3341 /app-misc/flasm/flasm-1.63.ebuild
parentVersion bump for bug #333121. Remove old, broken version; closes bugs #321203... (diff)
downloadhistorical-dbc9d9a0009b77dce57c2dc25ab4e4415c5cbdc0.tar.gz
historical-dbc9d9a0009b77dce57c2dc25ab4e4415c5cbdc0.tar.bz2
historical-dbc9d9a0009b77dce57c2dc25ab4e4415c5cbdc0.zip
Version bump, fixes 332041
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-misc/flasm/flasm-1.63.ebuild')
-rw-r--r--app-misc/flasm/flasm-1.63.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-misc/flasm/flasm-1.63.ebuild b/app-misc/flasm/flasm-1.63.ebuild
new file mode 100644
index 000000000000..e6322f622a00
--- /dev/null
+++ b/app-misc/flasm/flasm-1.63.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/flasm-1.63.ebuild,v 1.1 2010/08/30 23:37:30 xmw Exp $
+
+EAPI=2
+
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(delete_all_version_separators $(get_version_component_range 1-2))
+DESCRIPTION="Command line assembler/disassembler of Flash ActionScript bytecode"
+HOMEPAGE="http://www.nowrap.de/flasm.html"
+SRC_URI="http://www.nowrap.de/download/flasm${MY_PV}src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ dev-util/gperf"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin flasm || die
+ dodoc CHANGES.TXT || die
+ dohtml flasm.html classic.css || die
+}