summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-06 06:40:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-06 06:40:05 +0000
commitbfd1741ab1673fb3f3e04305935bd9ba034fafd2 (patch)
tree5dbaf700d47e92d2558c7e4a2af7886ca1be3a1e /app-misc/egads/egads-0.9.5.ebuild
parentMarking ~amd64 at Brad House's request. (diff)
downloadhistorical-bfd1741ab1673fb3f3e04305935bd9ba034fafd2.tar.gz
historical-bfd1741ab1673fb3f3e04305935bd9ba034fafd2.tar.bz2
historical-bfd1741ab1673fb3f3e04305935bd9ba034fafd2.zip
initial commit, ebuild by robbat2@gentoo.org.
Diffstat (limited to 'app-misc/egads/egads-0.9.5.ebuild')
-rw-r--r--app-misc/egads/egads-0.9.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/egads/egads-0.9.5.ebuild b/app-misc/egads/egads-0.9.5.ebuild
new file mode 100644
index 000000000000..1bb7ec414870
--- /dev/null
+++ b/app-misc/egads/egads-0.9.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/egads/egads-0.9.5.ebuild,v 1.1 2004/01/06 06:40:05 robbat2 Exp $
+
+DESCRIPTION="EGADS - Entropy Gathering And Distribution System"
+HOMEPAGE="http://www.securesoftware.com/download_${PN}.htm"
+SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/glibc"
+
+egadsdatadir=/var/run/egads
+
+src_compile() {
+ econf --with-egads-datadir="${egadsdatadir}" --with-bindir=/usr/sbin || die
+ emake || die
+
+
+}
+
+src_install () {
+ keepdir ${egadsdatadir}
+ fperm +t ${egadsdatadir}
+ einstall BINDIR=${D}/usr/sbin || die
+ dodoc README* doc/*.txt
+ dohtml doc/*.html
+}
+