summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-23 17:59:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-23 17:59:25 +0000
commit703870020409390e75ff208b995f77f55fc612ce (patch)
treec3562e760d1bd7798e34e3ca9f694724abe0ece0 /app-misc/dnetc/dnetc-2.9011.496-r1.ebuild
parentInitial import. Closing bug #147468. (diff)
downloadhistorical-703870020409390e75ff208b995f77f55fc612ce.tar.gz
historical-703870020409390e75ff208b995f77f55fc612ce.tar.bz2
historical-703870020409390e75ff208b995f77f55fc612ce.zip
Some minor cleanups and removing older and unused ebuilds. Hopefully, I'll get this all cleaned up so that at least the ebuilds are as similar as possible. Patches are always welcome. ;]
Package-Manager: portage-2.1.3.6
Diffstat (limited to 'app-misc/dnetc/dnetc-2.9011.496-r1.ebuild')
-rw-r--r--app-misc/dnetc/dnetc-2.9011.496-r1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild b/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild
index ed0e6faee66b..41a37834bbfc 100644
--- a/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild
+++ b/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild,v 1.6 2007/07/02 14:16:13 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9011.496-r1.ebuild,v 1.7 2007/08/23 17:59:25 wolf31o2 Exp $
inherit eutils
@@ -11,10 +11,13 @@ DESCRIPTION="distributed.net client"
HOMEPAGE="http://www.distributed.net"
SRC_URI="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )
amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64-elf.tar.gz )"
+
LICENSE="distributed.net"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND=""
RDEPEND="net-dns/bind-tools"
@@ -24,7 +27,16 @@ elif use x86; then
S="${WORKDIR}/dnetc${MIN_PV}-linux-x86-elf-uclibc"
fi
-RESTRICT="mirror"
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd ${FILESDIR}/dnetc.init-r1 dnetc
+ newconfd ${FILESDIR}/dnetc.conf dnetc
+}
pkg_preinst() {
if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
@@ -47,17 +59,6 @@ pkg_preinst() {
enewuser dnetc -1 -1 /opt/distributed.net dnetc
}
-src_install() {
- exeinto /opt/distributed.net
- doexe dnetc
-
- doman dnetc.1
- dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
-
- newinitd ${FILESDIR}/dnetc.init-r1 dnetc
- newconfd ${FILESDIR}/dnetc.conf dnetc
-}
-
pkg_postinst() {
chown -Rf dnetc:dnetc /opt/distributed.net
chmod 0555 /opt/distributed.net/dnetc