summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-08-23 17:59:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-08-23 17:59:25 +0000
commit703870020409390e75ff208b995f77f55fc612ce (patch)
treec3562e760d1bd7798e34e3ca9f694724abe0ece0 /app-misc/dnetc/dnetc-2.9003.481-r1.ebuild
parentInitial import. Closing bug #147468. (diff)
downloadhistorical-703870020409390e75ff208b995f77f55fc612ce.tar.gz
historical-703870020409390e75ff208b995f77f55fc612ce.tar.bz2
historical-703870020409390e75ff208b995f77f55fc612ce.zip
Some minor cleanups and removing older and unused ebuilds. Hopefully, I'll get this all cleaned up so that at least the ebuilds are as similar as possible. Patches are always welcome. ;]
Package-Manager: portage-2.1.3.6
Diffstat (limited to 'app-misc/dnetc/dnetc-2.9003.481-r1.ebuild')
-rw-r--r--app-misc/dnetc/dnetc-2.9003.481-r1.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild b/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild
index acfd281d881a..7e7631e7198d 100644
--- a/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild
+++ b/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild,v 1.11 2007/07/02 14:16:13 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9003.481-r1.ebuild,v 1.12 2007/08/23 17:59:25 wolf31o2 Exp $
MAJ_PV=${PV:0:6}
MIN_PV=${PV:7:9}
@@ -12,12 +12,16 @@ SRC_URI="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-l
x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf.tar.gz )
sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc.tar.gz )
alpha? ( ftp://ftp.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-alpha5-static.tar.gz )"
+
LICENSE="distributed.net"
SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
+KEYWORDS="alpha ppc sparc x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND=""
RDEPEND="net-dns/bind-tools"
+
if use x86; then
S="${WORKDIR}/dnetc${MIN_PV}-linux-x86-elf"
elif use ppc; then
@@ -30,17 +34,6 @@ elif use alpha; then
S="${WORKDIR}/dnetc${MIN_PV}-linux-alpha5-static"
fi
-RESTRICT="mirror"
-
-pkg_preinst() {
- if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
- einfo "flushing old buffers"
- /opt/distributed.net/dnetc -quiet -flush
- einfo "removing old buffer files"
- rm -f /opt/distributed.net/buff*
- fi
-}
-
src_install() {
exeinto /opt/distributed.net
doexe dnetc
@@ -52,6 +45,15 @@ src_install() {
newconfd ${FILESDIR}/dnetc.conf dnetc
}
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ /opt/distributed.net/dnetc -quiet -flush
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+}
+
pkg_postinst() {
elog "Either configure your email address in /etc/conf.d/dnetc"
elog "or create the configuration file /opt/distributed.net/dnetc.ini"