summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2004-10-23 10:04:00 +0000
committerAkinori Hattori <hattya@gentoo.org>2004-10-23 10:04:00 +0000
commit96a0ac03aea4e184f1d3cf2196a4e2aeeeacd2b6 (patch)
tree145a6ea6d2d7218446ae4dc68c45140c7b6500da /app-i18n
parentRemoved old ebuilds. (diff)
downloadhistorical-96a0ac03aea4e184f1d3cf2196a4e2aeeeacd2b6.tar.gz
historical-96a0ac03aea4e184f1d3cf2196a4e2aeeeacd2b6.tar.bz2
historical-96a0ac03aea4e184f1d3cf2196a4e2aeeeacd2b6.zip
version bump
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/anthy-ss/ChangeLog7
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-5822.ebuild68
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-58221
-rw-r--r--app-i18n/scim/Manifest12
5 files changed, 84 insertions, 8 deletions
diff --git a/app-i18n/anthy-ss/ChangeLog b/app-i18n/anthy-ss/ChangeLog
index b0c07ed10e4d..c26698531a39 100644
--- a/app-i18n/anthy-ss/ChangeLog
+++ b/app-i18n/anthy-ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/anthy-ss
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.53 2004/10/18 15:48:12 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.54 2004/10/23 10:04:00 hattya Exp $
+
+*anthy-ss-5822 (23 Oct 2004)
+
+ 23 Oct 2004; Akinori Hattori <hattya@gentoo.org> +anthy-ss-5822.ebuild:
+ version bump.
19 Oct 2004; Akinori Hattori <hattya@gentoo.org> -anthy-ss-5812.ebuild:
this version has a bug. shared libraries don't have ".so" suffix.
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 1e3a325bd689..7560d32e4dd5 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,7 +1,9 @@
-MD5 1808e83ae402d1ddaa141dfb7b2ade88 ChangeLog 7185
+MD5 a536b8aa26f481518c31ca553f0af97a ChangeLog 7306
MD5 b5fd09519b3fb7600e367696fd4feb8f anthy-ss-5714.ebuild 1496
MD5 624d6fc526c7ff8a40d163569a083405 anthy-ss-5818.ebuild 1496
+MD5 2b08489f68f10cfbb2e64e970b5821ee anthy-ss-5822.ebuild 1496
MD5 bae17b53f1633ca708e67b8762933954 metadata.xml 616
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 c46e2a82231884e714d609923e5ee847 files/digest-anthy-ss-5714 63
MD5 5000812dd61960e8c6e4782396ebadb3 files/digest-anthy-ss-5818 63
+MD5 7a908ccfbcf25763c79f895c21bcead9 files/digest-anthy-ss-5822 63
diff --git a/app-i18n/anthy-ss/anthy-ss-5822.ebuild b/app-i18n/anthy-ss/anthy-ss-5822.ebuild
new file mode 100644
index 000000000000..3c0607639a77
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-5822.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-5822.ebuild,v 1.1 2004/10/23 10:04:00 hattya Exp $
+
+inherit elisp-common
+
+IUSE="emacs ucs4"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/11968/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="EMACS=no"
+ use ucs4 && myconf="${myconf} --enable-ucs4"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" mkanthydic/Makefile.in
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" mkanthydic/Makefile.in
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc [A-Z][A-Z]* ChangeLog doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-5822 b/app-i18n/anthy-ss/files/digest-anthy-ss-5822
new file mode 100644
index 000000000000..26ecd043f1ee
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-5822
@@ -0,0 +1 @@
+MD5 f0dc47d81f04a17dc235ab9b2b13297f anthy-5822.tar.gz 1566583
diff --git a/app-i18n/scim/Manifest b/app-i18n/scim/Manifest
index 66e7194aaf02..2e4f0be365a3 100644
--- a/app-i18n/scim/Manifest
+++ b/app-i18n/scim/Manifest
@@ -1,10 +1,10 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 37d51de30a1d094ff0708ff1f66fd5ae ChangeLog 6489
+MD5 6acd7f9af5ab8c5e144da71a0f81cc30 ChangeLog 6590
MD5 e92a48548554c80cf90e18df17ff6a82 metadata.xml 156
MD5 c21fdcca07deaaf6cae39d96902f9469 scim-0.9.7.ebuild 2153
-MD5 55111fb99fceae178265efadb16e98bd scim-1.0.1.ebuild 3133
+MD5 799f384f4aad7f369481b95ebc23ef01 scim-1.0.1.ebuild 3130
MD5 b794a9e49a7db678e13f7e617334cf4f scim-1.0.0-r2.ebuild 3133
MD5 d86c4d5f55ed787493e72180ae6e69cc scim-0.99.8.ebuild 2819
MD5 4b50ec45c69e938123b22d03e8049859 files/digest-scim-0.9.7 63
@@ -13,9 +13,9 @@ MD5 ce0f75383c966331dfcad6088ec9daba files/digest-scim-1.0.0-r2 63
MD5 95e4d06699356649f034690e3c3e870e files/scim-0.6.1-gtk2immodule.patch 545
MD5 da242924a42bdb73b70898a598f6ad07 files/digest-scim-0.99.8 64
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
+Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBY57hVWNWqTUmv+0RAgp4AJ0ecTecVRUWDvcwb9bkMMjEygUyJQCbBs/C
-RPPTU7tvdslTXtYN75NGt3o=
-=7d5C
+iD8DBQFBeiulVWNWqTUmv+0RAgNMAKCMN51blrk8cfGr7BmjmHK32Vrp4ACgikl7
+r/IjNzv2LZV8yomwcYwyjs4=
+=lQis
-----END PGP SIGNATURE-----