summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-19 14:14:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-19 14:14:07 +0000
commit0fa0ef1c05ad1785ac5832ebcf4035628e4c6bbc (patch)
treed7de8a37f84a291fe8f47b82558df35a91d81d11 /app-i18n
parentAutomated update of use.local.desc (diff)
downloadhistorical-0fa0ef1c05ad1785ac5832ebcf4035628e4c6bbc.tar.gz
historical-0fa0ef1c05ad1785ac5832ebcf4035628e4c6bbc.tar.bz2
historical-0fa0ef1c05ad1785ac5832ebcf4035628e4c6bbc.zip
Version bumped.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-m17n/ChangeLog8
-rw-r--r--app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild56
-rw-r--r--app-i18n/ibus-table/Manifest4
-rw-r--r--app-i18n/ibus/ChangeLog8
-rw-r--r--app-i18n/ibus/ibus-0.1.1.20081016.ebuild99
5 files changed, 172 insertions, 3 deletions
diff --git a/app-i18n/ibus-m17n/ChangeLog b/app-i18n/ibus-m17n/ChangeLog
index 2fad22f1ced7..767103430f9b 100644
--- a/app-i18n/ibus-m17n/ChangeLog
+++ b/app-i18n/ibus-m17n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-m17n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.2 2008/10/09 15:04:17 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ChangeLog,v 1.3 2008/10/19 14:14:07 matsuu Exp $
+
+*ibus-m17n-0.1.1.20081013 (19 Oct 2008)
+
+ 19 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-m17n-0.1.1.20081013.ebuild:
+ Version bumped.
*ibus-m17n-0.1.1.20081009 (09 Oct 2008)
diff --git a/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild b/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild
new file mode 100644
index 000000000000..9b10ad400f70
--- /dev/null
+++ b/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-m17n/ibus-m17n-0.1.1.20081013.ebuild,v 1.1 2008/10/19 14:14:07 matsuu Exp $
+
+inherit python
+
+DESCRIPTION="The M17N engine IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ dev-libs/m17n-lib
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ dev-db/m17n-db
+ dev-db/m17n-contrib
+ >=sys-devel/gettext-0.16.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_compile() {
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog
+ elog "You should run ibus-setup and enable IM Engines you want to use!"
+ elog
+ python_mod_optimize /usr/share/${PN}/engine
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/engine
+}
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 021fcf6c6ef8..0d24f45e54bd 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1,4 +1,6 @@
DIST ibus-table-0.1.1.20080901.tar.gz 5782829 RMD160 35dc8ab0bd965f78760f9695f82003551fcbf0df SHA1 741e2b942353dd2b11eb7ca40f295054c8ecab14 SHA256 527a68bef26a259cd6cd1d27404c88b74842363a6b566c53b34574cb4c927bcf
+DIST ibus-table-0.1.1.20081014.tar.gz 5468162 RMD160 7a72d6be1dc48bec346977b742b838f2e863c098 SHA1 c1658d6d731441e4d8f2fd15cc69eb9e2f37f8c1 SHA256 1e4b0305711ba7b16daf23faa18de0b7da9a9596c02c93259205ec435e848211
EBUILD ibus-table-0.1.1.20080901.ebuild 1514 RMD160 2e0b6d9a86b6d49bbdff2999bea3fd57dd65a712 SHA1 b9d79f2f5dcb2aee773cc38ddb0ea3eb8a80c02d SHA256 a56bd928057fe2bde252f69a510f86de221a2184122a350094ef784c50d1c92e
-MISC ChangeLog 386 RMD160 178717d1c7b8596e64c80c852f7958a014f04582 SHA1 c70cf5019b218782225b278d3f9b2cd6bb1b3605 SHA256 f88db4ab7beeaa1b6b86cdb2908f537c59303c204e985f2d780b796c1271bfd6
+EBUILD ibus-table-0.1.1.20081014.ebuild 1751 RMD160 857bf7e7368385bb0f9c1f6977d26f62c7f68f3e SHA1 baecd2c4a9d6bca21d796941d1d6493e8437a25a SHA256 8580bf9d500e1c8fafd28992b0346341cd821268e7c5b2a5a33319592f2b2e0a
+MISC ChangeLog 549 RMD160 556cb1763bf0336b0b6655baf63a824b8e8c9a31 SHA1 8fc879353fbca99090a5b2d28023b361f88dea40 SHA256 95eab40ecd7dd01c39ca5c96e39cd6d9ab9e88f9f983a5056be068d2d83e16d0
MISC metadata.xml 686 RMD160 cc99bce8a2a51e6550104ab9389451b3f820ca94 SHA1 878809845a75da6bc4bfe463aa811910da482358 SHA256 55c16cf48e9313eb1117b6e0a8bfbf70d2bb06d8915e817eb6fa069da302c06b
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 5285ac131f5d..d719e0b0e918 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.12 2008/10/15 15:58:40 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.13 2008/10/19 14:11:20 matsuu Exp $
+
+*ibus-0.1.1.20081016 (19 Oct 2008)
+
+ 19 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +ibus-0.1.1.20081016.ebuild:
+ Version bumped.
*ibus-0.1.1.20081006-r1 (15 Oct 2008)
diff --git a/app-i18n/ibus/ibus-0.1.1.20081016.ebuild b/app-i18n/ibus/ibus-0.1.1.20081016.ebuild
new file mode 100644
index 000000000000..f584e711e764
--- /dev/null
+++ b/app-i18n/ibus/ibus-0.1.1.20081016.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-0.1.1.20081016.ebuild,v 1.1 2008/10/19 14:11:20 matsuu Exp $
+
+EAPI="1"
+inherit autotools eutils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls qt4"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ dev-libs/dbus-glib
+ qt4? ( || (
+ (
+ >=x11-libs/qt-core-4.4:4
+ >=x11-libs/qt-dbus-4.4:4
+ )
+ >=x11-libs/qt-4.4:4
+ ) )
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg
+ x11-misc/notification-daemon
+ || (
+ dev-python/gconf-python
+ dev-python/gnome-python
+ )"
+
+pkg_setup() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ sed -i -e '/QMAKE/s/$/ "CONFIG+=nostrip"/' client/qt4/Makefile.am || die
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable qt4 qt4-immodule) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ local qt_im_module="xim"
+ use qt4 && qt_im_module="ibus"
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog "2. Set the following in your"
+ elog " user startup scripts such as .xinitrc or .bashrc"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"${qt_im_module}\""
+ elog " ibus &"
+
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ [ "${ROOT}" = "/" -a -x /usr/bin/gtk-query-immodules-2.0 ] && \
+ gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
+
+ python_mod_cleanup /usr/share/${PN}
+}