summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-11-02 16:26:01 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-11-02 16:26:01 +0000
commit440d582a041781065f877cd2dace6c556b23395c (patch)
tree7f5d073289d547637ffc431ce7362668b4293b50 /app-i18n/jless/jless-382.262.ebuild
parentVersion bump (diff)
downloadhistorical-440d582a041781065f877cd2dace6c556b23395c.tar.gz
historical-440d582a041781065f877cd2dace6c556b23395c.tar.bz2
historical-440d582a041781065f877cd2dace6c556b23395c.zip
Fixed HOMEPAGE, LICENSE and DEPEND. Removed pkg_postinst. Added eautoreconf, bug #240008.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64
Diffstat (limited to 'app-i18n/jless/jless-382.262.ebuild')
-rw-r--r--app-i18n/jless/jless-382.262.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-i18n/jless/jless-382.262.ebuild b/app-i18n/jless/jless-382.262.ebuild
new file mode 100644
index 000000000000..f750bb0bce5b
--- /dev/null
+++ b/app-i18n/jless/jless-382.262.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jless/jless-382.262.ebuild,v 1.1 2008/11/02 16:26:01 matsuu Exp $
+
+inherit autotools eutils
+
+LESS_P="less-${PV%%.*}"
+
+DESCRIPTION="Jam less is an enhancement of less which supports multibyte character"
+HOMEPAGE="http://www25.big.jp/~jam/less/"
+JAM_URI="http://www25.big.jp/~jam/less"
+SRC_URI="mirror://gnu/less/${LESS_P}.tar.gz
+ ${JAM_URI}/${LESS_P}-iso258.patch.gz
+ ${JAM_URI}/${LESS_P}-iso258-259.patch.gz
+ ${JAM_URI}/${LESS_P}-iso259-260.patch.gz
+ ${JAM_URI}/${LESS_P}-iso260-261.patch.gz
+ ${JAM_URI}/${LESS_P}-iso261-262.patch.gz"
+
+LICENSE="|| ( GPL-2 less )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+S="${WORKDIR}/${LESS_P}"
+
+src_unpack() {
+ unpack ${LESS_P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}/${LESS_P}-iso258.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso258-259.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso259-260.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso260-261.patch.gz"
+ epatch "${DISTDIR}/${LESS_P}-iso261-262.patch.gz"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf --without-cs-regex --with-editor="${EDITOR}" || die
+ emake || die
+}
+
+src_install() {
+ einstall binprefix=j manprefix=j || die
+
+ newbin "${FILESDIR}/lesspipe.sh-r1" jlesspipe.sh || die
+ doenvd "${FILESDIR}/70jless" || die
+
+ dodoc NEWS README*
+}