summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-06 08:43:17 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-06 08:43:17 +0000
commitd9bf75e4b5442c2dc37ffd1cc76201536f97181d (patch)
tree3aa612eed2452e058f933f236f3a345edae9ef23 /app-forensics/examiner/examiner-0.5-r2.ebuild
parentVersion bump (bug #437302). Remove old. (diff)
downloadhistorical-d9bf75e4b5442c2dc37ffd1cc76201536f97181d.tar.gz
historical-d9bf75e4b5442c2dc37ffd1cc76201536f97181d.tar.bz2
historical-d9bf75e4b5442c2dc37ffd1cc76201536f97181d.zip
New revision, fixes bug #241256 and a lot of QA issues. Bumped to EAPI 4
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/examiner/examiner-0.5-r2.ebuild')
-rw-r--r--app-forensics/examiner/examiner-0.5-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-forensics/examiner/examiner-0.5-r2.ebuild b/app-forensics/examiner/examiner-0.5-r2.ebuild
new file mode 100644
index 000000000000..e42304615b75
--- /dev/null
+++ b/app-forensics/examiner/examiner-0.5-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/examiner/examiner-0.5-r2.ebuild,v 1.1 2012/10/06 08:43:17 pinkbyte Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Application that utilizes the objdump command to disassemble and comment foreign executable binaries"
+HOMEPAGE="http://www.academicunderground.org/examiner/"
+SRC_URI="http://www.academicunderground.org/examiner/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ # Do not install docs through Makefile wrt bug #241256
+ sed -i -e '/$(DOC)/d' Makefile || die 'sed failed'
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ epatch "${FILESDIR}"/${P}-perl.patch
+ dodir /usr/bin /usr/share/examiner /usr/share/man/man1
+
+ make MAN="${D}/usr/share/man/man1" \
+ BIN="${D}/usr/bin" SHARE="${D}/usr/share/examiner" install
+ dodoc docs/{README*,BUGS,CHANGELOG,TODO,TUTORIAL}
+ dodoc -r utils
+}