summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-10 19:28:27 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-10 19:28:27 +0000
commitf8e54af8ffdfe8e33bef85f1dd4a29076d4cefb5 (patch)
tree64e5388a9362eb18a313ab904e224d7231e10ebe /app-emulation
parentminor cleanup (diff)
downloadhistorical-f8e54af8ffdfe8e33bef85f1dd4a29076d4cefb5.tar.gz
historical-f8e54af8ffdfe8e33bef85f1dd4a29076d4cefb5.tar.bz2
historical-f8e54af8ffdfe8e33bef85f1dd4a29076d4cefb5.zip
Version bumped.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-200403093
-rw-r--r--app-emulation/wine/wine-20040309.ebuild124
4 files changed, 136 insertions, 2 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 6314945eec34..ea107a491185 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.66 2004/03/10 17:27:02 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.67 2004/03/10 19:28:27 mholzer Exp $
+
+*wine-20040309 (10 Mar 2004)
+
+ 10 Mar 2004; Martin Holzer <mholzer@gentoo.org> wine-20040309.ebuild:
+ Version bumped.
10 Mar 2004; Martin Holzer <mholzer@gentoo.org> wine-20040121.ebuild:
x86 stable
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 6bdae726b905..7bc4f1644ab9 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -3,8 +3,10 @@ MD5 6fdf5aa621de320098b0b2c50a074f5a wine-20031212.ebuild 3262
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 6209435f285d13c563be57b73babffee wine-20031118-r1.ebuild 3398
MD5 12f40553553adbe6690d56f98c2a2a59 wine-20040213.ebuild 3263
-MD5 f8b656e3864a30d2a025ac9a7fcd0410 ChangeLog 11745
+MD5 f961cca3929b41f79b2dfd3ff78e3fc3 ChangeLog 11866
+MD5 ddee2aba59eb994e485f7c9fa806c3aa wine-20040309.ebuild 3263
MD5 b5307649654483532930907b0485eaf0 files/wine-alsa.patch 86359
+MD5 8eb0a0c62fa1579183fab16d341cbcdd files/digest-wine-20040309 212
MD5 5aab2a3ecd0a2d07663439a38ccc0d19 files/digest-wine-20040213 211
MD5 70f57f0783539581a5444df64b0784c4 files/digest-wine-20031212 211
MD5 52cb259a2838a89b23a6f00ef4b98bd0 files/digest-wine-20040121 211
diff --git a/app-emulation/wine/files/digest-wine-20040309 b/app-emulation/wine/files/digest-wine-20040309
new file mode 100644
index 000000000000..135af8523654
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20040309
@@ -0,0 +1,3 @@
+MD5 6d0a23943481e703a7d3538269f788e0 Wine-20040309.tar.gz 10060696
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20040309-fake_windows.tar.bz2 500
+MD5 674d52c1985297ae269ff0af8df8e62b wine-20040309-misc.tar.bz2 5154
diff --git a/app-emulation/wine/wine-20040309.ebuild b/app-emulation/wine/wine-20040309.ebuild
new file mode 100644
index 000000000000..25a855b04361
--- /dev/null
+++ b/app-emulation/wine/wine-20040309.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20040309.ebuild,v 1.1 2004/03/10 19:28:27 mholzer Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${PF}-misc.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl debug"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+}
+
+src_compile() {
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ `use_enable opengl` \
+ `use_with nptl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${PF}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine winedbg
+ rm regedit-wine wine winedbg
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}