summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2005-05-04 16:11:40 +0000
committerHanno Boeck <hanno@gentoo.org>2005-05-04 16:11:40 +0000
commitef180a9a7fab116cf0e3b58ec1d719177828bd4a (patch)
treecfb4f5d7080a815f28d410e6b2a5852fda3e48e7 /app-emulation
parentstable on x86 (diff)
downloadhistorical-ef180a9a7fab116cf0e3b58ec1d719177828bd4a.tar.gz
historical-ef180a9a7fab116cf0e3b58ec1d719177828bd4a.tar.bz2
historical-ef180a9a7fab116cf0e3b58ec1d719177828bd4a.zip
vice gcc4 fix
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vice/ChangeLog6
-rw-r--r--app-emulation/vice/Manifest9
-rw-r--r--app-emulation/vice/files/vice_gcc4_patch.gzbin0 -> 1805 bytes
-rw-r--r--app-emulation/vice/vice-1.16.ebuild10
4 files changed, 18 insertions, 7 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 85aff913b559..c4be32006f28 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.23 2005/04/24 11:15:49 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.24 2005/05/04 16:11:40 hanno Exp $
+
+ 04 May 2005; Hanno Boeck <hanno@gentoo.org> +files/vice_gcc4_patch.gz,
+ vice-1.16.ebuild:
+ GCC 4 fix (from Debian, already applied by upstream devs).
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> vice-1.14-r1.ebuild:
Stable on ppc.
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 52a0e907b04a..7bf560958614 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,8 +1,9 @@
-MD5 646f411d56e6d4b45b68ce7852a916c0 vice-1.16.ebuild 1710
+MD5 9692e416b6b624a221ce77378db3026f ChangeLog 3101
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 4a96fa06bc382c0759efd0bf5debf486 ChangeLog 2947
MD5 82f3d4f22bfa9ba4e54202f7785a7b4e vice-1.14-r1.ebuild 1429
-MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14-r1 62
+MD5 bb088854ff7d616c15ae4d0b47682180 vice-1.16.ebuild 1786
MD5 5467080b8555dc1bad201449fbdaf87e files/1.14-console-security.patch 3709
-MD5 fd15ab780139d6d1ff8ed8c0d5d85f90 files/digest-vice-1.16 62
MD5 962c8cfd8a9a308b180e1a26c4973625 files/1.14-po-Makefile.patch 560
+MD5 eca7586b8ef1c0d8665368c0328f9250 files/digest-vice-1.14-r1 62
+MD5 fd15ab780139d6d1ff8ed8c0d5d85f90 files/digest-vice-1.16 62
+MD5 818e0e7dbc321296c08530856f1c297a files/vice_gcc4_patch.gz 1805
diff --git a/app-emulation/vice/files/vice_gcc4_patch.gz b/app-emulation/vice/files/vice_gcc4_patch.gz
new file mode 100644
index 000000000000..292db7ce1c51
--- /dev/null
+++ b/app-emulation/vice/files/vice_gcc4_patch.gz
Binary files differ
diff --git a/app-emulation/vice/vice-1.16.ebuild b/app-emulation/vice/vice-1.16.ebuild
index 23f05a456e5c..2afe6180f5a7 100644
--- a/app-emulation/vice/vice-1.16.ebuild
+++ b/app-emulation/vice/vice-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.16.ebuild,v 1.2 2005/02/14 09:17:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.16.ebuild,v 1.3 2005/05/04 16:11:40 hanno Exp $
inherit games
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="arts gnome nls sdl X Xaw3d"
+IUSE="arts gnome nls sdl X Xaw3d readline"
# FIXME: esound is required until configure.in is patched.
DEPEND="virtual/libc
@@ -25,6 +25,12 @@ DEPEND="virtual/libc
X? ( virtual/x11 )
Xaw3d? ( x11-libs/Xaw3d )"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/vice_gcc4_patch.gz
+}
+
+
src_compile() {
# disabled ffmpeg support since ffmpeg isn't slotted and later
# versions aren't compatible with the vice code (bug #81795)