summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2003-08-17 20:28:38 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2003-08-17 20:28:38 +0000
commite17ede0e504a77366bf13e767852c97eee101028 (patch)
treed714017ee95bd2830182ec562175d37960d799a1 /app-emulation
parentAdded <longdescription> to metadata.xml. (diff)
downloadhistorical-e17ede0e504a77366bf13e767852c97eee101028.tar.gz
historical-e17ede0e504a77366bf13e767852c97eee101028.tar.bz2
historical-e17ede0e504a77366bf13e767852c97eee101028.zip
New version
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/win4lin/ChangeLog10
-rw-r--r--app-emulation/win4lin/files/digest-win4lin-5.0.41
-rw-r--r--app-emulation/win4lin/metadata.xml12
-rw-r--r--app-emulation/win4lin/win4lin-5.0.4.ebuild89
4 files changed, 110 insertions, 2 deletions
diff --git a/app-emulation/win4lin/ChangeLog b/app-emulation/win4lin/ChangeLog
index 20030f5c27ad..c07e2291536a 100644
--- a/app-emulation/win4lin/ChangeLog
+++ b/app-emulation/win4lin/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for app-emulation/win4lin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.10 2003/06/29 20:06:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.11 2003/08/17 20:28:38 bass Exp $
+
+*win4lin-5.0.4 (17 Aug 2003)
+
+ 17 Aug 2003; J.Alberto Suárez L. <bass@gentoo.org> win4lin-5.0.4.ebuild:
+ New version.
+ This version has beta support to glibc-2.3.2.
*win4lin-5.0.1 (03 Jun 2003)
19 Jun 2003; J.Alberto Suárez L. <bass@gentoo.org> win4lin-5.0.1.ebuild:
- Masrked as stable.
+ Marked as stable.
03 Jun 2003; J.Alberto Suárez L. <bass@gentoo.org> win4lin-5.0.1.ebuild:
New version and new evaluation code.
diff --git a/app-emulation/win4lin/files/digest-win4lin-5.0.4 b/app-emulation/win4lin/files/digest-win4lin-5.0.4
new file mode 100644
index 000000000000..f46dc2862180
--- /dev/null
+++ b/app-emulation/win4lin/files/digest-win4lin-5.0.4
@@ -0,0 +1 @@
+MD5 a99d319e2b0e6cf00bc494a588f26130 Win4Lin-5.5.4d-d.i386.rpm 4903395
diff --git a/app-emulation/win4lin/metadata.xml b/app-emulation/win4lin/metadata.xml
new file mode 100644
index 000000000000..3a36201a244c
--- /dev/null
+++ b/app-emulation/win4lin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bass@gentoo.org</email>
+ <name>José Alberto Suárez López</name>
+</maintainer>
+<longdescription>
+The NeTraverse product suite delivers the fastest and most cost-effective, resource-efficient, high-performance solution for running Windows applications on Linux.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/win4lin/win4lin-5.0.4.ebuild b/app-emulation/win4lin/win4lin-5.0.4.ebuild
new file mode 100644
index 000000000000..4e52d2902eaa
--- /dev/null
+++ b/app-emulation/win4lin/win4lin-5.0.4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-5.0.4.ebuild,v 1.1 2003/08/17 20:28:38 bass Exp $
+
+IUSE="doc"
+
+MY_P=Win4Lin-5.5.4d-d.i386
+
+S=${WORKDIR}
+DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
+under linux."
+HOMEPAGE="http://www.netraverse.com/"
+SRC_URI="mirror://gentoo/${MY_P}.rpm"
+# doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
+
+SLOT="0"
+LICENSE="NeTraverse"
+KEYWORDS="~x86"
+
+DEPEND="app-arch/rpm2targz
+ virtual/winkernel"
+RDEPEND="!<=app/emulation/win4lin-4.0.22"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_compile() {
+ einfo "nothing to compile; binary package."
+ einfo "Remember you need a kernel patched like"
+ einfo "win4lin-sources or gs-sources."
+}
+
+src_install() {
+ mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
+ cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
+ cp ${FILESDIR}/win4lin.initd.new ${D}/opt/win4lin/
+
+# if [ -n "`use doc`" ]
+# then
+# dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
+# fi
+}
+
+
+pkg_postinst() {
+ /opt/win4lin/postinst_rpm.sh
+ echo "LICENSE_CODE=1w5e055x-n0ca34-xjhx-xx3c-4c3c-73" > /var/win4lin/install/license.lic
+ einfo "If this is a new Win4Lin Install you will need to run the following command"
+ einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo "to install the windows setup files. You will need your Windows cdrom in the "
+ einfo "drive in order to complete this step."
+ einfo "============"
+ einfo "If this is an upgrade 4.x to 5.x the trial license code isn't valid,"
+ einfo "you need register it in NeTraverse, or unemerge ALL Win4Lin files."
+
+}
+
+
+pkg_prerm() {
+ /opt/win4lin/remove_rpm.sh
+}
+
+pkg_config() {
+ loadwindowsCD cddevice /dev/cdrom
+ cp /opt/win4lin/win4lin.initd.new /etc/init.d/Win4Lin
+ chmod +x /etc/init.d/Win4Lin
+
+ #put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo "You can now run the command \"installwindows\" from an xterm "
+ einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo "will use for that user."
+ einfo
+ einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
+ einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
+ einfo 'must run "sh /opt/win4lin/registerme.sh"'
+ einfo
+ einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
+ einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
+ einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
+ einfo 'Thanks Netaverse.'
+ einfo
+ einfo 'Remember, you must do "/etc/init.d/Win4Lin start" before start w4l'
+ einfo 'Also you can add it to default boot "rc-update add Win4Lin default"'
+ fi
+}