summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-01 16:54:57 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-01 16:54:57 +0000
commit1204d3488d11346ac574c0b0926887eebefe6c8f (patch)
tree786f10066e2e84562424fd270963cd81f74b27d7 /app-emulation
parentprune old ebuilds (diff)
downloadhistorical-1204d3488d11346ac574c0b0926887eebefe6c8f.tar.gz
historical-1204d3488d11346ac574c0b0926887eebefe6c8f.tar.bz2
historical-1204d3488d11346ac574c0b0926887eebefe6c8f.zip
fix for #11426
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fceultra/ChangeLog5
-rw-r--r--app-emulation/fceultra/fceultra-081-r1.ebuild11
2 files changed, 14 insertions, 2 deletions
diff --git a/app-emulation/fceultra/ChangeLog b/app-emulation/fceultra/ChangeLog
index 92387d4b1d01..9f44773d8b6c 100644
--- a/app-emulation/fceultra/ChangeLog
+++ b/app-emulation/fceultra/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/fceultra
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/ChangeLog,v 1.7 2002/11/22 16:48:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/ChangeLog,v 1.8 2002/12/01 16:54:57 vapier Exp $
*fceultra-081-r1 (22 Nov 2002)
+ 01 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added a check that if the compiler is gcc3.x, the ebuild fails #11426
+
22 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
Added support for sdl version #11089
diff --git a/app-emulation/fceultra/fceultra-081-r1.ebuild b/app-emulation/fceultra/fceultra-081-r1.ebuild
index f9cd089fc8c1..9430c0a65265 100644
--- a/app-emulation/fceultra/fceultra-081-r1.ebuild
+++ b/app-emulation/fceultra/fceultra-081-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/fceultra-081-r1.ebuild,v 1.1 2002/11/22 16:48:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/fceultra-081-r1.ebuild,v 1.2 2002/12/01 16:54:57 vapier Exp $
+
+inherit gcc
MY_P=fceu
S=${WORKDIR}/${MY_P}
@@ -16,6 +18,13 @@ DEPEND="svga? ( media-libs/svgalib )
sdl? ( media-libs/libsdl )"
pkg_setup() {
+ if [ `gcc-major-version` == 3 ] && [ `gcc-minor-version` == 2 ] && [ ${ARCH} == "x86" ] ; then
+ eerror "Do not use gcc 3.2.x to compile the source code"
+ eerror "on 80x86/IA32 platforms. It has a code generation"
+ eerror "bug in it that will cause FCE Ultra to not work."
+ die "cant compile on x86 with gcc-3.2.x"
+ fi
+
use sdl && return 0
use svga && return 0