summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-01-11 18:17:19 +0000
committerUlrich Müller <ulm@gentoo.org>2012-01-11 18:17:19 +0000
commit7772d6ec29f357b560a8050c5a6cd718864a8ad5 (patch)
tree6bb7cb179b09d50dee6d29f1dcd65ab176746479 /app-emacs
parentStable for ppc/ppc64; bug #398239 (diff)
downloadhistorical-7772d6ec29f357b560a8050c5a6cd718864a8ad5.tar.gz
historical-7772d6ec29f357b560a8050c5a6cd718864a8ad5.tar.bz2
historical-7772d6ec29f357b560a8050c5a6cd718864a8ad5.zip
Version bump, security fix release from upstream.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/cedet/ChangeLog7
-rw-r--r--app-emacs/cedet/cedet-1.0.1.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-emacs/cedet/ChangeLog b/app-emacs/cedet/ChangeLog
index 9a5f263a3621..22a47f805871 100644
--- a/app-emacs/cedet/ChangeLog
+++ b/app-emacs/cedet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/cedet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.66 2012/01/10 07:14:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/ChangeLog,v 1.67 2012/01/11 18:17:19 ulm Exp $
+
+*cedet-1.0.1 (11 Jan 2012)
+
+ 11 Jan 2012; Ulrich Müller <ulm@gentoo.org> +cedet-1.0.1.ebuild:
+ Version bump, security fix release from upstream.
09 Jan 2012; Agostino Sarubbo <ago@gentoo.org> cedet-1.0-r1.ebuild:
Stable for AMD64, wrt security bug #398227
diff --git a/app-emacs/cedet/cedet-1.0.1.ebuild b/app-emacs/cedet/cedet-1.0.1.ebuild
new file mode 100644
index 000000000000..456f41b4be81
--- /dev/null
+++ b/app-emacs/cedet/cedet-1.0.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/cedet/cedet-1.0.1.ebuild,v 1.1 2012/01/11 18:17:19 ulm Exp $
+
+EAPI=4
+NEED_EMACS=22
+
+inherit elisp
+
+MY_P=${P/_}
+DESCRIPTION="CEDET: Collection of Emacs Development Environment Tools"
+HOMEPAGE="http://cedet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cedet/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+SITEFILE="50${PN}-gentoo.el"
+EMACSFLAGS="${EMACSFLAGS} -L ${S}/eieio -L ${S}/semantic -L ${S}/srecode \
+ -L ${S}/ede -L ${S}/speedbar -L ${S}/cogre"
+
+src_compile() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS}"
+}
+
+src_test() {
+ emake -j1 \
+ EMACS="${EMACS}" \
+ EMACSFLAGS="${EMACSFLAGS}" \
+ utest
+}
+
+src_install() {
+ local target file dir
+ find . -type d -name tests -prune -o -type f -print | while read target
+ do
+ file=${target##*/}
+ dir=${target%/*}; dir=${dir#./}
+ case "${file}" in
+ *~ | Makefile | *.texi | *-script | PRERELEASE_CHECKLIST \
+ | Project.ede | USING_CEDET_FROM_CVS | grammar-fw-ov.txt)
+ ;;
+ ChangeLog | README | AUTHORS | *NEWS | INSTALL \
+ | renamelist.txt | semanticdb.sh)
+ docinto "${dir}"
+ dodoc "${target}" ;;
+ *.el | *.by | *.wy)
+ # install grammar sources along with the elisp files, since
+ # the location where semantic expects them is not configurable
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}" ;;
+ *.elc)
+ # we are in a subshell, so collecting in a variable won't work
+ echo "${target}" >>"${T}/elc-list.txt" ;;
+ *.srt | *.xpm)
+ insinto "${SITEETC}/${PN}/${dir}"
+ doins "${target}" ;;
+ *.info* | grammar-fw-ov.png)
+ doinfo "${target}" ;;
+ *)
+ die "Unrecognised file ${target}" ;;
+ esac
+ done
+
+ # make sure that the compiled elisp files have a later time stamp than
+ # the corresponding sources, in order to suppress warnings at run time
+ while read target; do
+ dir=${target%/*}; dir=${dir#./}
+ insinto "${SITELISP}/${PN}/${dir}"
+ doins "${target}"
+ done <"${T}/elc-list.txt"
+
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}