summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 05:01:33 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 05:01:33 +0000
commit28154f6f0023ad941225b463770553984182ecb0 (patch)
treef97a01f3f92b2917a1fc0768155d5dc0687b0801 /app-emacs/inform-mode/inform-mode-1.5.8.ebuild
parentNew ebuild for Noia icons. (diff)
downloadhistorical-28154f6f0023ad941225b463770553984182ecb0.tar.gz
historical-28154f6f0023ad941225b463770553984182ecb0.tar.bz2
historical-28154f6f0023ad941225b463770553984182ecb0.zip
initial import
Diffstat (limited to 'app-emacs/inform-mode/inform-mode-1.5.8.ebuild')
-rw-r--r--app-emacs/inform-mode/inform-mode-1.5.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/inform-mode/inform-mode-1.5.8.ebuild b/app-emacs/inform-mode/inform-mode-1.5.8.ebuild
new file mode 100644
index 000000000000..b7f53e072d8a
--- /dev/null
+++ b/app-emacs/inform-mode/inform-mode-1.5.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/inform-mode/inform-mode-1.5.8.ebuild,v 1.1 2002/11/20 05:01:33 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="A major mode for editing Inform programs."
+HOMEPAGE="http://rupert-lane.org/inform-mode/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="virtual/emacs"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emacs --batch -f batch-byte-compile \
+ --no-site-file --no-init-file *.el \
+ || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/50inform-mode-gentoo.el
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}