summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/crypt++
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/crypt++')
-rw-r--r--app-emacs/crypt++/ChangeLog11
-rw-r--r--app-emacs/crypt++/crypt++-2.91.ebuild38
-rw-r--r--app-emacs/crypt++/files/50crypt++-gentoo.el6
-rw-r--r--app-emacs/crypt++/files/digest-crypt++-2.911
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/crypt++/ChangeLog b/app-emacs/crypt++/ChangeLog
new file mode 100644
index 000000000000..98d492c0025e
--- /dev/null
+++ b/app-emacs/crypt++/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/crypt++
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/crypt++/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*crypt++-2.91 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ crypt++-2.91.ebuild, files/50crypt-gentoo.el,
+ files/digest-crypt++-2.91 :
+
+ Initial import.
diff --git a/app-emacs/crypt++/crypt++-2.91.ebuild b/app-emacs/crypt++/crypt++-2.91.ebuild
new file mode 100644
index 000000000000..8c0f43c30061
--- /dev/null
+++ b/app-emacs/crypt++/crypt++-2.91.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/crypt++/crypt++-2.91.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Handle all sorts of compressed and encrypted files"
+HOMEPAGE="http://freshmeat.net/projects/crypt++/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50crypt++-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/crypt++.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/crypt++/files/50crypt++-gentoo.el b/app-emacs/crypt++/files/50crypt++-gentoo.el
new file mode 100644
index 000000000000..1c4f7b642a54
--- /dev/null
+++ b/app-emacs/crypt++/files/50crypt++-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; crypt++ site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'crypt++)
+
diff --git a/app-emacs/crypt++/files/digest-crypt++-2.91 b/app-emacs/crypt++/files/digest-crypt++-2.91
new file mode 100644
index 000000000000..6b4f86bcc4c5
--- /dev/null
+++ b/app-emacs/crypt++/files/digest-crypt++-2.91
@@ -0,0 +1 @@
+MD5 2436b8dd4e09f8a6e4bae83241a01730 crypt++-2.91.tar.bz2 29480